summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2004-10-01 08:33:58 +0000
committerScott W Taylor <swtaylor@gentoo.org>2004-10-01 08:33:58 +0000
commit61c50a06040895672972fa096e119c3ea612fcaf (patch)
tree9c0b12578583a20851f272b219854f44b2c57f17 /app-laptop
parenttweak comments (Manifest recommit) (diff)
downloadgentoo-2-61c50a06040895672972fa096e119c3ea612fcaf.tar.gz
gentoo-2-61c50a06040895672972fa096e119c3ea612fcaf.tar.bz2
gentoo-2-61c50a06040895672972fa096e119c3ea612fcaf.zip
plays nicely with kernel 2.6
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkpad/ChangeLog7
-rw-r--r--app-laptop/thinkpad/Manifest2
-rw-r--r--app-laptop/thinkpad/files/digest-thinkpad-5.71
-rw-r--r--app-laptop/thinkpad/thinkpad-5.7.ebuild66
4 files changed, 75 insertions, 1 deletions
diff --git a/app-laptop/thinkpad/ChangeLog b/app-laptop/thinkpad/ChangeLog
index 31434dd5a5be..32c0aafa8b09 100644
--- a/app-laptop/thinkpad/ChangeLog
+++ b/app-laptop/thinkpad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/thinkpad
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/ChangeLog,v 1.5 2004/07/19 02:36:46 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/ChangeLog,v 1.6 2004/10/01 08:33:58 swtaylor Exp $
+
+*thinkpad-5.7 (01 Oct 2004)
+
+ 01 Oct 2004; Scott W Taylor <swtaylor@gentoo.org> +thinkpad-5.7.ebuild:
+ new source, plays nicely with 2.6 kernel
18 Jul 2004; Robin H. Johnson <robbat2@gentoo.org> thinkpad-4.8.ebuild:
stable on x86.
diff --git a/app-laptop/thinkpad/Manifest b/app-laptop/thinkpad/Manifest
index 06b7852e0b1d..0bf404694f71 100644
--- a/app-laptop/thinkpad/Manifest
+++ b/app-laptop/thinkpad/Manifest
@@ -1,4 +1,5 @@
MD5 4a70cc077fe3d9a8b0cdd2c53c7dca05 thinkpad-4.3-r1.ebuild 2013
+MD5 6c8d021238362ba22e34d962111cb5cc thinkpad-5.7.ebuild 1864
MD5 8f937bd58ec01067fb6934e167863940 thinkpad-4.1.ebuild 1378
MD5 6276e915c068dd77ca68b01f74b7072c thinkpad-4.8.ebuild 2011
MD5 7aa3cb6bc3ef22b367a205a676fbc01f thinkpad-4.3.ebuild 1910
@@ -9,5 +10,6 @@ MD5 67a420196c59076408625a82b1b0f3eb files/digest-thinkpad-3.2 63
MD5 f6711c6d29ed136c770235acf6bebf4a files/digest-thinkpad-4.1 63
MD5 c4bd4b11c836429cb452ababe9575efd files/digest-thinkpad-4.3 63
MD5 feffa2e3a3d70a62bd850ad019807206 files/digest-thinkpad-4.8 63
+MD5 94ca61fed5cf33f3a408cca8edad7d0b files/digest-thinkpad-5.7 63
MD5 26886c3a2e8b9c3b807371e643dd5c75 files/thinkpad 545
MD5 c4bd4b11c836429cb452ababe9575efd files/digest-thinkpad-4.3-r1 63
diff --git a/app-laptop/thinkpad/files/digest-thinkpad-5.7 b/app-laptop/thinkpad/files/digest-thinkpad-5.7
new file mode 100644
index 000000000000..38eb904eef42
--- /dev/null
+++ b/app-laptop/thinkpad/files/digest-thinkpad-5.7
@@ -0,0 +1 @@
+MD5 ec975f15656b5f3c98075a528d9cb9d6 thinkpad_5.7.tar.gz 75918
diff --git a/app-laptop/thinkpad/thinkpad-5.7.ebuild b/app-laptop/thinkpad/thinkpad-5.7.ebuild
new file mode 100644
index 000000000000..6b5a07df1e4d
--- /dev/null
+++ b/app-laptop/thinkpad/thinkpad-5.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-5.7.ebuild,v 1.1 2004/10/01 08:33:58 swtaylor Exp $
+
+inherit eutils
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+DESCRIPTION="Thinkpad system control kernel modules"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+pkg_setup() {
+ enewgroup thinkpad
+}
+
+src_unpack() {
+ check_KV
+ unpack ${A} || die
+ cd ${S}
+ local ver=${KV:0:3} # first 3 chars of $KV, thank you bash :)
+ ln -s $ver/drivers drivers
+ ln -s $ver/include include
+}
+
+src_compile() {
+ unset ARCH
+ MAKEOPTS="" emake all || die "Make failed"
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodir /lib/modules/${KV}/thinkpad
+ [ -e "${S}/drivers/thinkpad.ko" ] && MOD="ko" || MOD="o"
+ cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.${MOD} \
+ ${D}/lib/modules/${KV}/thinkpad
+ dodir /etc/modules.d
+ sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad
+ dodir /etc/devfs.d
+ einfo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664' \
+ > ${D}/etc/devfs.d/thinkpad
+ doman man/*.4
+}
+
+pkg_postinst() {
+ [ "${ROOT}" == "/" ] && /usr/sbin/update-modules
+ if ! grep -q '^ *INCLUDE.*devfs\.d' /etc/devfsd.conf; then
+ ewarn 'Your /etc/devfsd.conf is missing the include for'
+ ewarn '/etc/devfs.d/! Please fix this by adding'
+ ewarn 'INCLUDE /etc/devfs.d'
+ ewarn 'to your /etc/devfs.conf'
+ fi
+ if grep -q thinkpad /etc/devfsd.conf; then
+ ewarn 'The thinkpad devfsd entry has moved to'
+ ewarn '/etc/devfs.d/thinkpad, so you can remove it from'
+ ewarn '/etc/devfsd.conf if you like.'
+ fi
+}