summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-09-22 20:20:26 +0000
committerHanno Böck <hanno@gentoo.org>2008-09-22 20:20:26 +0000
commita4e3dbddc1dfa233a7599d283849a8296e084490 (patch)
treea68f6ac5a82202ff4e12e99187fa2089e310295e /app-laptop
parentstop using bindnow flags, bug #226981 (diff)
downloadgentoo-2-a4e3dbddc1dfa233a7599d283849a8296e084490.tar.gz
gentoo-2-a4e3dbddc1dfa233a7599d283849a8296e084490.tar.bz2
gentoo-2-a4e3dbddc1dfa233a7599d283849a8296e084490.zip
tp_smapi support for 2.6.27
(Portage version: 2.2_rc9/cvs/Linux 2.6.27-rc7 x86_64)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tp_smapi/ChangeLog6
-rw-r--r--app-laptop/tp_smapi/files/thinkpad_ec_semaphore.patch11
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.37.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index a73a4ffd8649..36e18b894fa8 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/tp_smapi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.26 2008/07/31 11:52:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.27 2008/09/22 20:20:25 hanno Exp $
+
+ 22 Sep 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/thinkpad_ec_semaphore.patch, tp_smapi-0.37.ebuild:
+ Add support for 2.6.27.
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-laptop/tp_smapi/files/thinkpad_ec_semaphore.patch b/app-laptop/tp_smapi/files/thinkpad_ec_semaphore.patch
new file mode 100644
index 000000000000..d18fb5f3a319
--- /dev/null
+++ b/app-laptop/tp_smapi/files/thinkpad_ec_semaphore.patch
@@ -0,0 +1,11 @@
+--- tp_smapi-0.37/thinkpad_ec.c.orig 2008-09-22 22:12:09.000000000 +0200
++++ tp_smapi-0.37/thinkpad_ec.c 2008-09-22 22:12:16.000000000 +0200
+@@ -36,7 +36,7 @@
+ #include <linux/delay.h>
+ #include <linux/thinkpad_ec.h>
+ #include <linux/jiffies.h>
+-#include <asm/semaphore.h>
++#include <linux/semaphore.h>
+ #include <asm/io.h>
+
+ #define TP_VERSION "0.37"
diff --git a/app-laptop/tp_smapi/tp_smapi-0.37.ebuild b/app-laptop/tp_smapi/tp_smapi-0.37.ebuild
index 8f8cea4183de..b9bcfaec329d 100644
--- a/app-laptop/tp_smapi/tp_smapi-0.37.ebuild
+++ b/app-laptop/tp_smapi/tp_smapi-0.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.37.ebuild,v 1.2 2008/03/31 08:34:42 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.37.ebuild,v 1.3 2008/09/22 20:20:25 hanno Exp $
inherit linux-mod linux-info
@@ -48,6 +48,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/thinkpad_ec_semaphore.patch"
+
# Remove usage of `sudo` in Makefile.
sed -i 's,sudo ,,' Makefile
}