summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-09-09 04:48:54 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-09-09 04:48:54 +0000
commite589845ba7f0f6cf554c04b918710ba68589aaaa (patch)
tree3fcbe0949ef3f03ec78d0c466186850d29932460 /app-laptop
parentversion bump (diff)
downloadgentoo-2-e589845ba7f0f6cf554c04b918710ba68589aaaa.tar.gz
gentoo-2-e589845ba7f0f6cf554c04b918710ba68589aaaa.tar.bz2
gentoo-2-e589845ba7f0f6cf554c04b918710ba68589aaaa.zip
Added debug option.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog6
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.6.6.ebuild10
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild9
3 files changed, 14 insertions, 11 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index cd85d6bf96ae..34bf9d171ba3 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.30 2005/08/11 00:59:09 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.31 2005/09/09 04:48:54 josejx Exp $
+
+ 09 Sep 2005; Joseph Jezak <josejx@gentoo.org> pbbuttonsd-0.6.6.ebuild,
+ pbbuttonsd-0.7.1.ebuild:
+ Added debug option.
11 Aug 2005; Olivier Crête <tester@gentoo.org> pbbuttonsd-0.7.1.ebuild:
Added acpi use flag for x86 and added ~x86 keywords, bug #87222 and #86566
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.6.6.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.6.6.ebuild
index 01de06aa5a60..53553abcbe6f 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.6.6.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.6.6.ebuild,v 1.4 2005/02/19 05:31:28 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.6.6.ebuild,v 1.5 2005/09/09 04:48:54 josejx Exp $
inherit eutils
@@ -11,18 +11,14 @@ SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc"
-IUSE=""
+IUSE="debug"
DEPEND="virtual/libc
>=sys-apps/baselayout-1.8.6.12-r1"
RDEPEND=""
-src_unpack() {
- unpack ${A}
-}
-
src_compile() {
- econf || die "sorry, failed to configure pbbuttonsd"
+ econf $(use_enable debug) || die "sorry, failed to configure pbbuttonsd"
emake || die "sorry, failed to compile pbbuttonsd"
}
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild
index 0187f5ee3336..f1acbe89952e 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild,v 1.3 2005/08/11 02:03:50 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild,v 1.4 2005/09/09 04:48:54 josejx Exp $
inherit eutils linux-info
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE="acpi"
+IUSE="acpi debug"
DEPEND="virtual/libc
>=sys-apps/baselayout-1.8.6.12-r1"
@@ -34,7 +34,8 @@ src_compile() {
laptop=powerbook
fi
- econf laptop=$laptop || die "Sorry, failed to configure pbbuttonsd"
+ econf laptop=$laptop \
+ $(use_enable debug) || die "Sorry, failed to configure pbbuttonsd"
emake || die "Sorry, failed to compile pbbuttonsd"
}
@@ -60,4 +61,6 @@ pkg_postinst() {
einfo "try setting replace_pmud=yes in /etc/pbbuttonsd.conf and"
einfo "disabling PMUD"
fi
+r
+r
}