summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-03-08 21:54:30 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-03-08 21:54:30 +0000
commitb98605957aac32b56a2bda926a37d5e015e1026c (patch)
treeaf1c0f2cc9499549b3a243fac4aa30dec1be52b1 /app-leechcraft/lc-aggregator/lc-aggregator-0.5.85.ebuild
parentversion bump ESR for security bug 460818 (diff)
downloadgentoo-2-b98605957aac32b56a2bda926a37d5e015e1026c.tar.gz
gentoo-2-b98605957aac32b56a2bda926a37d5e015e1026c.tar.bz2
gentoo-2-b98605957aac32b56a2bda926a37d5e015e1026c.zip
Move LeechCraft to new category
(Portage version: 2.1.11.55/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-aggregator/lc-aggregator-0.5.85.ebuild')
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-0.5.85.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-0.5.85.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-0.5.85.ebuild
new file mode 100644
index 000000000000..8afbbf9c9812
--- /dev/null
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-0.5.85.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/lc-aggregator-0.5.85.ebuild,v 1.1 2013/03/08 21:54:30 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug mysql +sqlite postgres"
+
+DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="|| ( mysql sqlite postgres )"
+
+pkg_setup(){
+ if use mysql; then
+ ewarn "Support for MySQL databases is experimental and is more likely"
+ ewarn "to contain bugs or mishandle your data than other storage"
+ ewarn "backends. If you do not plan testing the MySQL storage backend"
+ ewarn "itself, consider using other backends."
+ ewarn "Anyway, it is perfectly safe to enable the mysql use flag as"
+ ewarn "long as at least one other storage is enabled since you will"
+ ewarn "be able to choose another storage backend at run time."
+ fi
+}