summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-03-08 21:55:25 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-03-08 21:55:25 +0000
commit0111ab4c45410064064dc0b0315ead5eede39308 (patch)
tree626cfc41b79968b5a32363aae1327f1cb2b3903e /app-leechcraft/lc-azoth/lc-azoth-0.5.90.ebuild
parentMove LeechCraft to new category (diff)
downloadgentoo-2-0111ab4c45410064064dc0b0315ead5eede39308.tar.gz
gentoo-2-0111ab4c45410064064dc0b0315ead5eede39308.tar.bz2
gentoo-2-0111ab4c45410064064dc0b0315ead5eede39308.zip
Move LeechCraft to new category
(Portage version: 2.1.11.55/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-azoth/lc-azoth-0.5.90.ebuild')
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-0.5.90.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/app-leechcraft/lc-azoth/lc-azoth-0.5.90.ebuild b/app-leechcraft/lc-azoth/lc-azoth-0.5.90.ebuild
new file mode 100644
index 000000000000..28f2d5ef1831
--- /dev/null
+++ b/app-leechcraft/lc-azoth/lc-azoth-0.5.90.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/lc-azoth-0.5.90.ebuild,v 1.1 2013/03/08 21:55:25 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+ +juick +keeso +lastseen +metacontacts media +msn +latex +nativeemoticons
+ +otroid +p100q +spell shx +standardstyles +xmpp +xtazy"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtwebkit:4
+ dev-qt/qtmultimedia:4
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ media? ( dev-qt/qtmultimedia:4 )
+ msn? ( net-libs/libmsn )
+ spell? ( app-text/hunspell )
+ xmpp? ( =net-libs/qxmpp-0.7* media-libs/speex )
+ xtazy? ( dev-qt/qtdbus:4 )
+ crypt? ( app-crypt/qca app-crypt/qca-gnupg )"
+RDEPEND="${DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable birthdaynotifier AZOTH_BIRTHDAYNOTIFIER)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable media MEDIACALLS)
+ $(cmake-utils_use_enable latex AZOTH_MODNOK)
+ $(cmake-utils_use_enable msn AZOTH_ZHEET)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable spell AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable shx AZOTH_SHX)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable xmpp AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}