summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-05-02 15:32:42 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-05-02 15:32:42 +0000
commit50c41cc4211183cd2373e0a7f102df95c094778e (patch)
tree29c05c29e229d70104a4cbef37e8ca1cd671849d /app-leechcraft/lc-monocle
parentBump LeechCraft to 0.5.95, thanks to 0xd34df00d (diff)
downloadgentoo-2-50c41cc4211183cd2373e0a7f102df95c094778e.tar.gz
gentoo-2-50c41cc4211183cd2373e0a7f102df95c094778e.tar.bz2
gentoo-2-50c41cc4211183cd2373e0a7f102df95c094778e.zip
Bump LeechCraft to 0.5.95, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-leechcraft/lc-monocle')
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog7
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.5.95.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index fa03bd9cf02a..61da1f666f78 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-monocle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.2 2013/04/14 16:18:51 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.3 2013/05/02 15:32:42 pinkbyte Exp $
+
+*lc-monocle-0.5.95 (02 May 2013)
+
+ 02 May 2013; Sergey Popov <pinkbyte@gentoo.org> +lc-monocle-0.5.95.ebuild:
+ Bump app-leechcraft/lc-monocle to 0.5.95, thanks to 0xd34df00d
14 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> lc-monocle-9999.ebuild:
Bump EAPI to 5, add documentation building and installing, thanks to
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.5.95.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.5.95.ebuild
new file mode 100644
index 000000000000..d676cce4c5a2
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.5.95.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.5.95.ebuild,v 1.1 2013/05/02 15:32:42 pinkbyte Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
+
+RDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? ( app-text/libspectre )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}