summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-04-14 15:12:46 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-04-14 15:12:46 +0000
commit721215249e07ccec07e20967793ebc7a9edc0100 (patch)
tree4f4016cc64ade690279f81d87e30491fc882aaa1 /app-leechcraft
parentOld. (diff)
downloadgentoo-2-721215249e07ccec07e20967793ebc7a9edc0100.tar.gz
gentoo-2-721215249e07ccec07e20967793ebc7a9edc0100.tar.bz2
gentoo-2-721215249e07ccec07e20967793ebc7a9edc0100.zip
Bump EAPI to 5, add documentation building and installing, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-azoth/ChangeLog6
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-9999.ebuild20
2 files changed, 19 insertions, 7 deletions
diff --git a/app-leechcraft/lc-azoth/ChangeLog b/app-leechcraft/lc-azoth/ChangeLog
index 218f5910d850..06a209ba3fa4 100644
--- a/app-leechcraft/lc-azoth/ChangeLog
+++ b/app-leechcraft/lc-azoth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-leechcraft/lc-azoth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/ChangeLog,v 1.1 2013/03/08 21:55:25 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/ChangeLog,v 1.2 2013/04/14 15:12:46 pinkbyte Exp $
+
+ 14 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> lc-azoth-9999.ebuild:
+ Bump EAPI to 5, add documentation building and installing, thanks to
+ 0xd34df00d
*lc-azoth-9999 (08 Mar 2013)
*lc-azoth-0.5.90 (08 Mar 2013)
diff --git a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
index f75dc5f8deda..10a370115418 100644
--- a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
+++ b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild,v 1.1 2013/03/08 21:55:25 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild,v 1.2 2013/04/14 15:12:46 pinkbyte Exp $
-EAPI="4"
+EAPI="5"
inherit leechcraft
-DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+DESCRIPTION="Azoth, the modular IM client for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+IUSE="debug doc astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+juick +keeso +lastseen +metacontacts media +msn +latex +nativeemoticons
+otroid +p100q +spell shx +standardstyles +xmpp +xtazy"
-DEPEND="~app-leechcraft/lc-core-${PV}
+COMMON_DEPEND="~app-leechcraft/lc-core-${PV}
dev-qt/qtwebkit:4
dev-qt/qtmultimedia:4
autoidler? ( x11-libs/libXScrnSaver )
@@ -27,7 +27,9 @@ DEPEND="~app-leechcraft/lc-core-${PV}
xmpp? ( =net-libs/qxmpp-9999 media-libs/speex )
xtazy? ( dev-qt/qtdbus:4 )
crypt? ( app-crypt/qca app-crypt/qca-gnupg )"
-RDEPEND="${DEPEND}
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${COMMON_DEPEND}
astrality? (
net-im/telepathy-mission-control
net-voip/telepathy-haze
@@ -45,6 +47,7 @@ REQUIRED_USE="|| ( standardstyles adiumstyles )"
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_with doc DOCS)
$(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
$(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
$(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
@@ -77,6 +80,11 @@ src_configure() {
cmake-utils_src_configure
}
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
+
pkg_postinst() {
if use spell; then
elog "You have enabled the Azoth Rosenthal plugin for"