summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-03-09 10:23:13 +0000
committerHans de Graaff <graaff@gentoo.org>2008-03-09 10:23:13 +0000
commit4c6f1966ce2a6a803815de82cd1f93060a674b64 (patch)
treea5fd68d97f623f362da92577974983911cb1e248 /app-misc/alexandria
parentamd64 stable, security bug #212488. (diff)
downloadgentoo-2-4c6f1966ce2a6a803815de82cd1f93060a674b64.tar.gz
gentoo-2-4c6f1966ce2a6a803815de82cd1f93060a674b64.tar.bz2
gentoo-2-4c6f1966ce2a6a803815de82cd1f93060a674b64.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc/alexandria')
-rw-r--r--app-misc/alexandria/ChangeLog12
-rw-r--r--app-misc/alexandria/alexandria-0.6.2.ebuild67
-rw-r--r--app-misc/alexandria/files/alexandria-0.6.2-rake-0.8.1.patch147
-rw-r--r--app-misc/alexandria/files/alexandria-rakefile.patch13
-rw-r--r--app-misc/alexandria/metadata.xml4
5 files changed, 241 insertions, 2 deletions
diff --git a/app-misc/alexandria/ChangeLog b/app-misc/alexandria/ChangeLog
index 82e750bc8402..fd9718e9d869 100644
--- a/app-misc/alexandria/ChangeLog
+++ b/app-misc/alexandria/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/alexandria
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.20 2007/09/17 20:04:37 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.21 2008/03/09 10:23:12 graaff Exp $
+
+*alexandria-0.6.2 (09 Mar 2008)
+
+ 09 Mar 2008; Hans de Graaff <graaff@gentoo.org>
+ +files/alexandria-0.6.2-rake-0.8.1.patch,
+ +files/alexandria-rakefile.patch, metadata.xml, +alexandria-0.6.2.ebuild:
+ Bump version based on ebuild in #207092. Add John Keeping as proxy maintainer
+ as discussed in the same bug.
17 Sep 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing citizen428 from metadata.xml (see #56803 for reference).
diff --git a/app-misc/alexandria/alexandria-0.6.2.ebuild b/app-misc/alexandria/alexandria-0.6.2.ebuild
new file mode 100644
index 000000000000..0e6304c4ccf4
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.6.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.2.ebuild,v 1.1 2008/03/09 10:23:12 graaff Exp $
+
+inherit ruby gnome2 eutils
+
+IUSE=""
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/29501/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+USE_RUBY="ruby18"
+
+DOCS="COPYING ChangeLog README TODO"
+
+RDEPEND=">=dev-lang/ruby-1.8.0
+ >=dev-ruby/ruby-gettext-0.6.1
+ >=dev-ruby/ruby-gnome2-0.14.0
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0
+ >=dev-ruby/ruby-gdkpixbuf2-0.12.0
+ >=dev-ruby/ruby-amazon-0.8.3
+ >=dev-ruby/ruby-zoom-0.2.0"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-ruby/rake"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-rakefile.patch"
+ epatch "${FILESDIR}/${P}-rake-0.8.1.patch"
+}
+
+src_compile() {
+ rake || die
+}
+
+src_install() {
+ export PREFIX="${D}/usr"
+ rake install || die
+
+ [ -n "${DOCS}" ] && dodoc ${DOCS}
+
+ # Move the installed docs to the gentoo standard directory
+ for doc in "${D}/usr/share/doc/alexandria/*"
+ do
+ dodoc $doc
+ done
+ rm -rf "${D}/usr/share/doc/alexandria"
+}
+
+pkg_postinst() {
+ unset PREFIX
+
+ gnome2_gconf_install
+
+ # For the next line see bug #76726
+ "${ROOT}/usr/bin/gconftool-2" --shutdown
+}
diff --git a/app-misc/alexandria/files/alexandria-0.6.2-rake-0.8.1.patch b/app-misc/alexandria/files/alexandria-0.6.2-rake-0.8.1.patch
new file mode 100644
index 000000000000..d99757994d21
--- /dev/null
+++ b/app-misc/alexandria/files/alexandria-0.6.2-rake-0.8.1.patch
@@ -0,0 +1,147 @@
+# Merge changes from upstream to fix compilation with rake 0.8.1
+
+--- tasks.rb.orig 2007-12-19 20:49:17.000000000 +0000
++++ tasks.rb 2008-02-07 11:33:54.000000000 +0000
+@@ -38,6 +38,7 @@
+ # these may be distributed as ordinary libraries,
+ # or as gems. Try the library versions first.
+ retrying_with_rubygems = false
++
+ begin
+ require 'rake'
+ require 'rake/tasklib'
+@@ -199,21 +200,35 @@
+ desc "Run RSpec specifications"
+ Spec::Rake::SpecTask.new("spec") do |t|
+ t.spec_files = @files.specs
+- t.spec_opts = ["--format", "specdoc"]
++ t.spec_opts = ["--format", "progress"]
+ end
++
+ namespace :spec do
++ Spec::Rake::SpecTask.new("autotest") do |t|
++ t.spec_files = @files.specs
++ t.spec_opts = ["--format", "progress"]
++ end
++
+ desc "Verify test coverage"
+ Spec::Rake::SpecTask.new("rcov") do |t|
+- t.spec_files = FileList['spec/**/*_spec.rb']
++ t.spec_files = @files.specs
+ t.spec_opts = ["--format", "specdoc"]
+ t.rcov_opts = ["--exclude", "spec"]
+ t.rcov = true
+ end
++ desc "Generate spec html"
+ Spec::Rake::SpecTask.new("html") do |t|
+- t.spec_files = FileList['spec/**/*_spec.rb']
++ t.spec_files = @files.specs
+ t.spec_opts = ["--format", "html"]
+ t.rcov_opts = ["--exclude", "spec"]
+ end
++ desc "Profile slowest examples"
++ Spec::Rake::SpecTask.new("profile") do |t|
++ t.spec_files = @files.specs
++ t.spec_opts = ["--format", "profile"]
++ t.rcov_opts = ["--exclude", "spec"]
++ end
++
+ desc "Run slower acceptance tests (real world data)"
+ Spec::Rake::SpecTask.new("acceptance") do |t|
+ t.spec_files = FileList['spec/acceptance/*_spec.rb']
+@@ -258,8 +273,8 @@
+ end
+ dest = source_path ? dest_basedir + source_path : dest_basedir
+ FileUtils.mkdir_p dest unless test ?d, dest
+- puts "Installing #{file} to #{dest}"
+- File.install(file.to_s, dest.to_s, mode)
++ puts "Installing #{file} to #{dest} with #{mode}"
++ FileUtils.install(file.to_s, dest.to_s, :mode => mode)
+ end
+
+ def define_install_tasks
+@@ -318,9 +333,9 @@
+
+ def base_installation
+ [
+- ['lib', build.files.libs, rubylib, 0644],
+- ['data', build.files.data, sharedir, 0644],
+- ['bin', build.files.programs, bindir, 0755]
++ ['lib', build.files.libs, rubylib, 0644],
++ ['data', build.files.data, sharedir, 0644],
++ ['bin', build.files.programs, bindir, 0755]
+ ]
+ end
+
+@@ -329,7 +344,7 @@
+ icon_group = []
+ build.files.icons.each do |filename|
+ filename =~ /.*\/(.+)\/.+/
+- size = $1
++ size = $1
+ dest = File.join(icon_dir, size, 'apps')
+ icon_group << [File.dirname(filename), filename, dest, 0644]
+ end
+@@ -357,8 +372,8 @@
+ end
+ end
+ [
+- ['doc', docdir_files, doc_dir, 0644],
+- ['.', curdir_files, doc_dir, 0644]
++ ['doc', docdir_files, doc_dir, 0644],
++ ['.', curdir_files, doc_dir, 0644]
+ ]
+ end
+
+@@ -388,7 +403,7 @@
+ def template_copy(src, dest, data)
+ src_text = File.open(src).read()
+ dest_text = src_text.gsub(/#(\w+)#/) { |match| data[$1.intern] }
+- FileUtils.mkdir_p(File.dirname(dest))
++ FileUtils.mkdir_p(File.dirname(dest))
+ File.open(dest, 'w') { |f| f.write(dest_text) }
+ end
+
+@@ -416,16 +431,16 @@
+ # HACK gconf
+ gconf_dir = File.join(@debinstall.staging_dir, "/usr/share/gconf/schemas")
+ FileUtils.mkdir_p(gconf_dir)
+- File.install("schemas/alexandria.schemas", gconf_dir, 0644)
++ FileUtils.install("schemas/alexandria.schemas", gconf_dir, 0644)
+
+ # HACK copyright
+ doc_dir = File.join(@debinstall.staging_dir, "/usr/share/doc/#{@name}")
+ FileUtils.mkdir_p(doc_dir)
+- File.install("debian/copyright", doc_dir, 0644)
++ FileUtils.install("debian/copyright", doc_dir, 0644)
+ FileUtils.rm_f(File.join(doc_dir, 'COPYING'))
+ FileUtils.rm_f(File.join(doc_dir, 'INSTALL'))
+- File.install("debian/README.Debian", doc_dir, 0644)
+- File.install("debian/changelog", doc_dir, 0644)
++ FileUtils.install("debian/README.Debian", doc_dir, 0644)
++ FileUtils.install("debian/changelog", doc_dir, 0644)
+
+ autogen_files = ["lib/alexandria/config.rb",
+ "lib/alexandria/version.rb",
+@@ -549,7 +564,7 @@
+ end
+ def locale_for(omf_file)
+ omf_file =~ /.*-(.+)\.omf/
+- $1
++ $1
+ end
+ def in_files
+ FileList["#{@omf_dir}/*.omf.in"]
+@@ -566,9 +581,9 @@
+ def define_gettext_tasks
+ # extract translations from PO files into other files
+ file files.desktop => ["#{files.desktop}.in",
+- *@gettext.po_files] do |f|
+- system("intltool-merge -d #{@gettext.po_dir} #{f.name}.in #{f.name}")
+- end
++ *@gettext.po_files] do |f|
++ raise "Need to install intltool" unless system("intltool-merge -d #{@gettext.po_dir} #{f.name}.in #{f.name}")
++ end
+
+ # create MO files
+ rule( /\.mo$/ => [ lambda { |dest| @gettext.source_file(dest) }]) do |t|
diff --git a/app-misc/alexandria/files/alexandria-rakefile.patch b/app-misc/alexandria/files/alexandria-rakefile.patch
new file mode 100644
index 000000000000..6686e0f787ac
--- /dev/null
+++ b/app-misc/alexandria/files/alexandria-rakefile.patch
@@ -0,0 +1,13 @@
+# Remove the post install tasks because it's not properly installed when
+# they run and portage does exactly the same things later anyway.
+
+--- Rakefile.orig 2008-01-23 22:25:02.000000000 +0000
++++ Rakefile 2008-01-23 22:25:50.000000000 +0000
+@@ -220,7 +220,5 @@
+ system("gtk-update-icon-cache -f -t /usr/share/icons/hicolor") # HACK
+ end
+
+-task :post_install => [:scrollkeeper, :gconf, :update_icon_cache]
+-
+
+ #vim: filetype=ruby syntax=Ruby
diff --git a/app-misc/alexandria/metadata.xml b/app-misc/alexandria/metadata.xml
index b9eb887dcf92..4102ef204cc8 100644
--- a/app-misc/alexandria/metadata.xml
+++ b/app-misc/alexandria/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer>
+ <email>john.keeping@lineone.net</email>
+ <name>John Keeping</name>
+ </maintainer>
<herd>ruby</herd>
<herd>gnome</herd>
</pkgmetadata>