summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-06-07 06:56:07 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-06-07 06:56:07 +0000
commit7c1762851c15ddd1425b089fbff9212148da7b74 (patch)
treeec8a416d3bcc73c44c41b63dc6820502032de60d /app-misc/beancounter/beancounter-0.8.8.ebuild
parentamd64 stable wrt #209877 (diff)
downloadgentoo-2-7c1762851c15ddd1425b089fbff9212148da7b74.tar.gz
gentoo-2-7c1762851c15ddd1425b089fbff9212148da7b74.tar.bz2
gentoo-2-7c1762851c15ddd1425b089fbff9212148da7b74.zip
Version bump, bug #221839. Added dev-perl/DBI to RDEPEND, appears it is needed. Also removed old versions, I don't think we need >3 versions in the tree
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc/beancounter/beancounter-0.8.8.ebuild')
-rw-r--r--app-misc/beancounter/beancounter-0.8.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/beancounter/beancounter-0.8.8.ebuild b/app-misc/beancounter/beancounter-0.8.8.ebuild
new file mode 100644
index 000000000000..f7d814c9c257
--- /dev/null
+++ b/app-misc/beancounter/beancounter-0.8.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beancounter/beancounter-0.8.8.ebuild,v 1.1 2008/06/07 06:56:07 darkside Exp $
+
+inherit perl-app
+
+DESCRIPTION="Finance performance calculation engine with full data acquisition and SQL backend support"
+HOMEPAGE="http://dirk.eddelbuettel.com/code/beancounter.html"
+SRC_URI="http://eddelbuettel.com/dirk/code/beancounter/beancounter_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="mysql postgres sqlite"
+
+DEPEND=">=dev-lang/perl-5
+ dev-perl/DateManip
+ dev-perl/Statistics-Descriptive
+ dev-perl/Finance-YahooQuote
+ dev-perl/libwww-perl
+ mysql? ( dev-perl/DBD-mysql )
+ sqlite? ( dev-perl/DBD-SQLite )
+ postgres? ( dev-perl/DBD-Pg )"
+
+RDEPEND="dev-perl/DBI"
+
+mydoc="BUGS THANKS TODO example.* *.txt"