summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-01-26 10:05:25 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-01-26 10:05:25 +0000
commitfd612e12dc4a27ded27e2c4605f9b0f5e9885934 (patch)
treeaada40481dd17c2be6f8ba79f56f0f205b966631 /app-misc/bonnie++
parentupgrade to beta30 (diff)
downloadgentoo-2-fd612e12dc4a27ded27e2c4605f9b0f5e9885934.tar.gz
gentoo-2-fd612e12dc4a27ded27e2c4605f9b0f5e9885934.tar.bz2
gentoo-2-fd612e12dc4a27ded27e2c4605f9b0f5e9885934.zip
bonnie 1.02a ebuild contributed by William McArthur <leknor@leknor.com>
Diffstat (limited to 'app-misc/bonnie++')
-rw-r--r--app-misc/bonnie++/bonnie++-1.02a.ebuild40
-rw-r--r--app-misc/bonnie++/files/digest-bonnie++-1.02a1
2 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/bonnie++/bonnie++-1.02a.ebuild b/app-misc/bonnie++/bonnie++-1.02a.ebuild
new file mode 100644
index 000000000000..b2f7df6c2071
--- /dev/null
+++ b/app-misc/bonnie++/bonnie++-1.02a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author William McArthur <leknor@leknor.com>
+# $HEADER $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Hard drive bottleneck testing benchmark suite."
+SRC_URI="http://www.coker.com.au/bonnie++/${P}.tgz"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ if [ "$DEBUG" == "true" ]
+ then
+ myconf="--with-debug --disable-stripping"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myconf || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ # make install doesn't respect DESTDIR or anything else.
+ #make DESTDIR=${D} install || die "make install failed"
+ # make install-bin will respect eprefix but would still need clean up
+ #make eprefix=${D} install-bin || die "make install-bin failed"
+
+ # Explicit
+ dobin bonnie++ zcav
+ dobin bon_csv2html bon_csv2txt
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt copyright.txt credits.txt
+}
diff --git a/app-misc/bonnie++/files/digest-bonnie++-1.02a b/app-misc/bonnie++/files/digest-bonnie++-1.02a
new file mode 100644
index 000000000000..bab2e39b8d49
--- /dev/null
+++ b/app-misc/bonnie++/files/digest-bonnie++-1.02a
@@ -0,0 +1 @@
+MD5 1fc1c4eb78c4938d8e654890a0cdc452 bonnie++-1.02a.tgz 57344