summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-01-04 09:17:38 +0000
committerTim Harder <radhermit@gentoo.org>2012-01-04 09:17:38 +0000
commitb019172ca83060db36405001015bed387a9841a1 (patch)
treeeb0fd89930da0f210bbef0a6ad8ef4a21f20b67b /app-misc/byobu/byobu-5.1.ebuild
parentmedia-libs/libmp3splt: 0.7.1 (diff)
downloadgentoo-2-b019172ca83060db36405001015bed387a9841a1.tar.gz
gentoo-2-b019172ca83060db36405001015bed387a9841a1.tar.bz2
gentoo-2-b019172ca83060db36405001015bed387a9841a1.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/byobu/byobu-5.1.ebuild')
-rw-r--r--app-misc/byobu/byobu-5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/byobu/byobu-5.1.ebuild b/app-misc/byobu/byobu-5.1.ebuild
new file mode 100644
index 000000000000..e97f5ebb0b72
--- /dev/null
+++ b/app-misc/byobu/byobu-5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-5.1.ebuild,v 1.1 2012/01/04 09:17:38 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="A set of profiles for the GNU Screen console window manager (app-misc/screen)"
+HOMEPAGE="https://launchpad.net/byobu"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-misc/screen app-misc/tmux )
+ dev-libs/newt"
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Create symlinks for backends
+ dosym ${PN} /usr/bin/${PN}-screen
+ dosym ${PN} /usr/bin/${PN}-tmux
+}