summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-31 20:01:54 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-31 20:01:54 +0000
commite8effef8d063d5069c7f76c298abeeba8b30c771 (patch)
treeb730ed65736ebe09b8a5c4e07e7d2b71fa6ce5f2 /app-misc/conmux
parentFix changelog (diff)
downloadgentoo-2-e8effef8d063d5069c7f76c298abeeba8b30c771.tar.gz
gentoo-2-e8effef8d063d5069c7f76c298abeeba8b30c771.tar.bz2
gentoo-2-e8effef8d063d5069c7f76c298abeeba8b30c771.zip
Revbump to fix helpers and drivers installation. Fix PATH in init scripts and typos
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-misc/conmux')
-rw-r--r--app-misc/conmux/ChangeLog9
-rw-r--r--app-misc/conmux/conmux-0.15.1-r1.ebuild (renamed from app-misc/conmux/conmux-0.15.1.ebuild)10
-rwxr-xr-xapp-misc/conmux/files/conmux-registry.initd14
-rwxr-xr-xapp-misc/conmux/files/conmux.initd8
4 files changed, 30 insertions, 11 deletions
diff --git a/app-misc/conmux/ChangeLog b/app-misc/conmux/ChangeLog
index 2c82d3de1cd7..9a7780f5940e 100644
--- a/app-misc/conmux/ChangeLog
+++ b/app-misc/conmux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/conmux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/conmux/ChangeLog,v 1.1 2013/10/29 21:12:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/conmux/ChangeLog,v 1.2 2013/10/31 20:01:54 hwoarang Exp $
+
+*conmux-0.15.1-r1 (31 Oct 2013)
+
+ 31 Oct 2013; Markos Chandras <hwoarang@gentoo.org> +conmux-0.15.1-r1.ebuild,
+ -conmux-0.15.1.ebuild, files/conmux-registry.initd, files/conmux.initd:
+ Revbump to fix helpers and drivers installation. Fix PATH in init scripts and
+ typos
*conmux-0.15.1 (29 Oct 2013)
diff --git a/app-misc/conmux/conmux-0.15.1.ebuild b/app-misc/conmux/conmux-0.15.1-r1.ebuild
index 236d9ce1e516..85f6f167c570 100644
--- a/app-misc/conmux/conmux-0.15.1.ebuild
+++ b/app-misc/conmux/conmux-0.15.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/conmux/conmux-0.15.1.ebuild,v 1.1 2013/10/29 21:12:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/conmux/conmux-0.15.1-r1.ebuild,v 1.1 2013/10/31 20:01:54 hwoarang Exp $
EAPI=5
@@ -19,9 +19,17 @@ RDEPEND="dev-perl/IO-Multiplex
dev-perl/URI"
DEPEND=""
+src_prepare() {
+ # manual installation of drivers and helpers
+ sed -i -e "/include/d" Makefile || die "Failed to fix Makefile"
+}
+
src_install() {
perlinfo
emake BASE="${D}/usr" install
+ # helpers and drivers have been removed in src_prepare
+ insinto /usr/share/${PN}
+ doins -r drivers helpers
dodir /etc/${PN}
# no need to have the init script in /sbin
rm "${D}"/usr/sbin/start || die "failed to remove init script"
diff --git a/app-misc/conmux/files/conmux-registry.initd b/app-misc/conmux/files/conmux-registry.initd
index 736fecf6a8ac..4759d529e983 100755
--- a/app-misc/conmux/files/conmux-registry.initd
+++ b/app-misc/conmux/files/conmux-registry.initd
@@ -14,15 +14,17 @@ checkconfig() {
start() {
checkconfig
- ebegin "Starting conmux daemon"
- touch ${CONMUX_REGISTRY_LOG} ${CONMUX_REGISTRY_FILE}
- start-stop-daemon -b --start -p /run/conmux-registry.pid \
- --exec /usr/sbin/conmux-registry \
- ${CONMUX_REGISTRY_PORT} ${CONMUX_REGISTRY_FILE}
+ # Make sure conmux finds everything
+ export PATH="${PATH}:/usr/share/conmux/drivers:/usr/share/conmux/helpers"
+ ebegin "Starting conmux registry daemon"
+ touch ${CONMUX_REGISTRY_LOG}
+ start-stop-daemon -b -m --start -p /run/conmux-registry.pid \
+ --exec /usr/sbin/conmux-registry -- ${CONMUX_REGISTRY_PORT} \
+ ${CONMUX_REGISTRY_LOG}
}
stop() {
- ebegin "Stopping conmux daemon"
+ ebegin "Stopping conmux registry daemon"
start-stop-daemon --stop --pidfile /run/conmux-registry.pid
eend $?
}
diff --git a/app-misc/conmux/files/conmux.initd b/app-misc/conmux/files/conmux.initd
index 75f53de4445f..23485b547658 100755
--- a/app-misc/conmux/files/conmux.initd
+++ b/app-misc/conmux/files/conmux.initd
@@ -19,14 +19,16 @@ checkconfig() {
start() {
checkconfig || exit 1
- ebegin "Starting CONMUX daemon"
- start-stop-daemon -b --start -1 ${CONMUX_LOG} \
+ # Make sure conmux finds everything
+ export PATH="${PATH}:/usr/share/conmux/drivers:/usr/share/conmux/helpers"
+ ebegin "Starting conmux daemon"
+ start-stop-daemon -m b --start -1 ${CONMUX_LOG} \
-2 ${CONMUX_LOG} -p /run/conmux.pid \
--exec /usr/sbin/conmux -- ${CONMUX_CONFIG}
}
stop() {
- ebegin "Stopping CONMUX daemon"
+ ebegin "Stopping conmux daemon"
start-stop-daemon --stop --pidfile /run/conmux.pid
eend $?
}