summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-02-04 02:17:49 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-02-04 02:17:49 +0000
commit46dc1aee999f796d056fb17cf29f2646824c1a75 (patch)
tree8257de8f8932e987103bd7f56d4a55ca7add3d55 /app-misc/countrycodes
parentRemove old versions. (diff)
downloadgentoo-2-46dc1aee999f796d056fb17cf29f2646824c1a75.tar.gz
gentoo-2-46dc1aee999f796d056fb17cf29f2646824c1a75.tar.bz2
gentoo-2-46dc1aee999f796d056fb17cf29f2646824c1a75.zip
Fix pre-stripped files and get CC through tc-getCC. Bug #152253.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'app-misc/countrycodes')
-rw-r--r--app-misc/countrycodes/ChangeLog8
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5.ebuild15
-rw-r--r--app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch12
3 files changed, 31 insertions, 4 deletions
diff --git a/app-misc/countrycodes/ChangeLog b/app-misc/countrycodes/ChangeLog
index 7206e0b6261d..117ffc14d14d 100644
--- a/app-misc/countrycodes/ChangeLog
+++ b/app-misc/countrycodes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/countrycodes
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/ChangeLog,v 1.17 2006/12/04 20:45:35 eroyf Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/ChangeLog,v 1.18 2007/02/04 02:17:49 dirtyepic Exp $
+
+ 04 Feb 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/countrycodes-1.0.5-Makefile.patch, countrycodes-1.0.5.ebuild:
+ Fix pre-stripped files and get CC through tc-getCC. Bug #152253.
04 Dec 2006; Alexander H. Færøy <eroyf@gentoo.org>
countrycodes-1.0.5.ebuild:
diff --git a/app-misc/countrycodes/countrycodes-1.0.5.ebuild b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
index afcf57249c87..d5fa31f49e7b 100644
--- a/app-misc/countrycodes/countrycodes-1.0.5.ebuild
+++ b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.17 2006/12/04 20:45:35 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.18 2007/02/04 02:17:49 dirtyepic Exp $
+
+inherit eutils toolchain-funcs
DESCRIPTION="An ISO 3166 country code finder"
HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
@@ -15,6 +17,15 @@ RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
sys-apps/sed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ sed -i -e "s:gcc:$(tc-getCC):" src/Makefile || die "sed failed"
+}
+
src_compile() {
emake -C src CCOPTS="${CFLAGS}" || die "emake failed"
}
diff --git a/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch b/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch
new file mode 100644
index 000000000000..619d7a072360
--- /dev/null
+++ b/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch
@@ -0,0 +1,12 @@
+diff -Naur countrycodes-1.0.5-orig/src/Makefile countrycodes-1.0.5/src/Makefile
+--- countrycodes-1.0.5-orig/src/Makefile 2003-02-01 09:56:08.000000000 -0600
++++ countrycodes-1.0.5/src/Makefile 2007-02-03 20:12:26.000000000 -0600
+@@ -70,7 +70,7 @@
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
++ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
+ @echo "Installing man page..."
+ @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+ @chown 0.0 ${mandir}/iso3166.1