summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-10 09:43:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-10 09:43:54 +0000
commit7b594470957e6525524a6ccea93ddb96a22a7fd7 (patch)
tree46db210af4edd70cd979beb56661452037316399 /app-misc/countrycodes
parentdon't assign default to S; depend on sed >= 4; error check sed; use user CFLA... (diff)
downloadgentoo-2-7b594470957e6525524a6ccea93ddb96a22a7fd7.tar.gz
gentoo-2-7b594470957e6525524a6ccea93ddb96a22a7fd7.tar.bz2
gentoo-2-7b594470957e6525524a6ccea93ddb96a22a7fd7.zip
don't assign default to S; don't rdepend on sed; use emake; install man pages in proper location; tidy
Diffstat (limited to 'app-misc/countrycodes')
-rw-r--r--app-misc/countrycodes/ChangeLog7
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5.ebuild25
2 files changed, 21 insertions, 11 deletions
diff --git a/app-misc/countrycodes/ChangeLog b/app-misc/countrycodes/ChangeLog
index 0e4fb1f9a960..45978a2986da 100644
--- a/app-misc/countrycodes/ChangeLog
+++ b/app-misc/countrycodes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/countrycodes
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/ChangeLog,v 1.1 2004/02/29 22:10:15 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/ChangeLog,v 1.2 2004/04/10 09:43:54 mr_bones_ Exp $
+
+ 10 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ countrycodes-1.0.5.ebuild:
+ don't assign default to S; don't rdepend on sed; use emake; install man pages
+ in proper location; tidy
*countrycodes-1.0.5 (29 Feb 2004)
diff --git a/app-misc/countrycodes/countrycodes-1.0.5.ebuild b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
index 6ecf73434bf3..2e3cdadf3dcd 100644
--- a/app-misc/countrycodes/countrycodes-1.0.5.ebuild
+++ b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
@@ -1,27 +1,32 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.1 2004/02/29 22:10:15 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.2 2004/04/10 09:43:54 mr_bones_ Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="An ISO 3166 country code finder."
HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
-KEYWORDS="~x86"
SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~x86"
IUSE=""
-DEPEND="virtual/glibc
-sys-apps/sed"
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
src_compile() {
- make -C src $MAKEOPTS CCOPTS="$CFLAGS" || die
+ emake -C src $MAKEOPTS CCOPTS="$CFLAGS" || die "emake failed"
}
src_install () {
- dodir /usr/bin
- dodir /usr/man/man1
- make -C src prefix=${D}/usr install || die
+ dodir /usr/bin /usr/share/man/man1
+ make \
+ -C src \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" install || die "make install failed"
dosym iso3166 /usr/bin/countrycodes
- dodoc doc/Changelog doc/README doc/COPYING doc/INSTALL
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc doc/{Changelog,README}
+ prepman
}