summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-06 16:35:25 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-06 16:35:25 +0000
commit6a366d29abd9a7b8d62d71320f13fb58d79e127e (patch)
tree54b8abce84145ff987223538c1a1ce44fb199020 /app-misc/devtodo/devtodo-0.1.19.ebuild
parent(#86959) Stable on x86. (diff)
downloadgentoo-2-6a366d29abd9a7b8d62d71320f13fb58d79e127e.tar.gz
gentoo-2-6a366d29abd9a7b8d62d71320f13fb58d79e127e.tar.bz2
gentoo-2-6a366d29abd9a7b8d62d71320f13fb58d79e127e.zip
Version bump; not many changes. most upstream changes are already present in 0.1.18-r2. Added gcc-4 patch which is applicable for both 0.1.18-r2 and 0.1.19. Tidy'd old ebuilds and patches.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-misc/devtodo/devtodo-0.1.19.ebuild')
-rw-r--r--app-misc/devtodo/devtodo-0.1.19.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/devtodo/devtodo-0.1.19.ebuild b/app-misc/devtodo/devtodo-0.1.19.ebuild
new file mode 100644
index 000000000000..61ede5bcb627
--- /dev/null
+++ b/app-misc/devtodo/devtodo-0.1.19.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.19.ebuild,v 1.1 2005/06/06 16:35:25 ka0ttic Exp $
+
+inherit eutils gnuconfig bash-completion flag-o-matic
+
+DESCRIPTION="A nice command line todo list for developers"
+HOMEPAGE="http://swapoff.org/DevTodo"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.1.18-gcc4.diff
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ gnuconfig_update
+}
+
+src_compile() {
+ einfo "Running autoreconf"
+ autoreconf -f -i || die "autoreconf failed"
+ replace-flags -O[23] -O1
+ econf --sysconfdir=/etc/devtodo || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog QuickStart README doc/scripts.sh \
+ doc/scripts.tcsh doc/todorc.example || die "dodoc failed"
+
+ dobashcompletion contrib/${PN}.bash-completion ${PN}
+ rm contrib/${PN}.bash-completion
+ docinto contrib
+ dodoc contrib/*
+}
+
+pkg_postinst() {
+ echo
+ einfo "Because of a conflict with app-misc/tdl, the tdl symbolic link"
+ einfo "and manual page have been removed."
+ bash-completion_pkg_postinst
+}