summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-12-31 05:36:45 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-12-31 05:36:45 +0000
commit27647eca9ea964f0852f7c71d441cd0bc60a75d8 (patch)
tree8a3d48f560ec338ed5ff2c8186626b6f69fdb49f /app-misc/dnetc
parent(non maintainer commit) Version bump to latest - dropped arches due to added ... (diff)
downloadgentoo-2-27647eca9ea964f0852f7c71d441cd0bc60a75d8.tar.gz
gentoo-2-27647eca9ea964f0852f7c71d441cd0bc60a75d8.tar.bz2
gentoo-2-27647eca9ea964f0852f7c71d441cd0bc60a75d8.zip
(non maintianer commit) version bump. Thanks to Andrew MacKenzie for the submission in bug 248490
(Portage version: 2.2_rc20/cvs/Linux 2.6.27.10 x86_64)
Diffstat (limited to 'app-misc/dnetc')
-rw-r--r--app-misc/dnetc/ChangeLog8
-rw-r--r--app-misc/dnetc/dnetc-2.9101.507.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/app-misc/dnetc/ChangeLog b/app-misc/dnetc/ChangeLog
index 3f47e73be31a..d864209c77e9 100644
--- a/app-misc/dnetc/ChangeLog
+++ b/app-misc/dnetc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/dnetc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.51 2008/07/28 17:12:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.52 2008/12/31 05:36:45 darkside Exp $
+
+*dnetc-2.9101.507 (31 Dec 2008)
+
+ 31 Dec 2008; Jeremy Olexa <darkside@gentoo.org> +dnetc-2.9101.507.ebuild:
+ (non maintianer commit) version bump. Thanks to Andrew MacKenzie for the
+ submission in bug 248490
28 Jul 2008; Chris Gianelloni <wolf31o2@gentoo.org> metadata.xml:
Change to maintainer-needed.
diff --git a/app-misc/dnetc/dnetc-2.9101.507.ebuild b/app-misc/dnetc/dnetc-2.9101.507.ebuild
new file mode 100644
index 000000000000..5f58644e1f95
--- /dev/null
+++ b/app-misc/dnetc/dnetc-2.9101.507.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9101.507.ebuild,v 1.1 2008/12/31 05:36:45 darkside Exp $
+
+inherit eutils
+
+MAJ_PV=${PV:0:6}
+MIN_PV=${PV:7:9}
+
+DESCRIPTION="distributed.net client"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )
+ amd64? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-amd64-elf.tar.gz )"
+
+LICENSE="distributed.net"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="net-dns/bind-tools"
+
+if use amd64; then
+ S="${WORKDIR}/dnetc${MIN_PV}-linux-amd64-elf"
+elif use x86; then
+ S="${WORKDIR}/dnetc${MIN_PV}-linux-x86-elf-uclibc"
+fi
+
+src_install() {
+ exeinto /opt/distributed.net
+ doexe dnetc
+
+ doman dnetc.1
+ dodoc docs/CHANGES.txt docs/dnetc.txt docs/readme.*
+
+ newinitd "${FILESDIR}"/dnetc.initd dnetc
+ newconfd "${FILESDIR}"/dnetc.confd dnetc
+}
+
+pkg_preinst() {
+ if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
+ einfo "flushing old buffers"
+ source /etc/conf.d/dnetc
+
+ if [ -e /opt/distributed.net/dnetc.ini ]; then
+ # use ini file
+ /opt/distributed.net/dnetc -quiet -ini /opt/distributed.net/dnetc.ini -flush
+ elif [ ! -e /opt/distributed.net/dnetc.ini ] && [ ! -z ${EMAIL} ]; then
+ # email adress from config
+ /opt/distributed.net/dnetc -quiet -flush -e ${EMAIL}
+ fi
+
+ einfo "removing old buffer files"
+ rm -f /opt/distributed.net/buff*
+ fi
+
+ enewgroup dnetc
+ enewuser dnetc -1 -1 /opt/distributed.net dnetc
+}
+
+pkg_postinst() {
+ chown -Rf dnetc:dnetc /opt/distributed.net
+ chmod 0555 /opt/distributed.net/dnetc
+
+ elog "To run distributed.net client in the background at boot:"
+ elog " rc-update add dnetc default"
+ elog ""
+ elog "Either configure your email address in /etc/conf.d/dnetc"
+ elog "or create the configuration file /opt/distributed.net/dnetc.ini"
+}
+
+pkg_postrm() {
+ if [ -d /opt/distributed.net ]; then
+ elog "All files has not been removed from /opt/distributed.net"
+ fi
+}