summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-11 07:08:30 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-11 07:08:30 +0000
commitfafa6fcef6d37f3f1759d11b5bc2ca56b4863019 (patch)
tree0edf87afcd508129b78d43a11e4dc010d7de3bc7 /app-misc/fslurp
parentVersion bump for gcc-4.5.3, apply improvements (more tool symlinks) from java... (diff)
downloadgentoo-2-fafa6fcef6d37f3f1759d11b5bc2ca56b4863019.tar.gz
gentoo-2-fafa6fcef6d37f3f1759d11b5bc2ca56b4863019.tar.bz2
gentoo-2-fafa6fcef6d37f3f1759d11b5bc2ca56b4863019.zip
Initial import.
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/fslurp')
-rw-r--r--app-misc/fslurp/ChangeLog10
-rw-r--r--app-misc/fslurp/files/fslurp-0.7-makefile.patch19
-rw-r--r--app-misc/fslurp/fslurp-0.7.ebuild34
-rw-r--r--app-misc/fslurp/metadata.xml14
4 files changed, 77 insertions, 0 deletions
diff --git a/app-misc/fslurp/ChangeLog b/app-misc/fslurp/ChangeLog
new file mode 100644
index 000000000000..d0b35a5f965e
--- /dev/null
+++ b/app-misc/fslurp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-misc/fslurp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fslurp/ChangeLog,v 1.1 2011/08/11 07:08:30 radhermit Exp $
+
+*fslurp-0.7 (11 Aug 2011)
+
+ 11 Aug 2011; Tim Harder <radhermit@gentoo.org> +fslurp-0.7.ebuild,
+ +files/fslurp-0.7-makefile.patch, +metadata.xml:
+ Initial import.
+
diff --git a/app-misc/fslurp/files/fslurp-0.7-makefile.patch b/app-misc/fslurp/files/fslurp-0.7-makefile.patch
new file mode 100644
index 000000000000..c8c34a3c32eb
--- /dev/null
+++ b/app-misc/fslurp/files/fslurp-0.7-makefile.patch
@@ -0,0 +1,19 @@
+--- fslurp-0.7/makefile.orig
++++ fslurp-0.7/makefile
+@@ -6,12 +6,14 @@
+
+ INCLUDES = fslurp.h fronius.h externs.h
+
+-CFLAGS = -Wall -lm
++CFLAGS += -Wall
++
++LIBS = -lm
+
+ VERSION := fslurp-$(shell tail -1 version)
+
+ fslurp: $(SOURCE) $(INCLUDES)
+- gcc $(CFLAGS) -o fslurp $(SOURCE)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o fslurp $(SOURCE) $(LIBS)
+
+ test: fslurp
+ ./fslurp
diff --git a/app-misc/fslurp/fslurp-0.7.ebuild b/app-misc/fslurp/fslurp-0.7.ebuild
new file mode 100644
index 000000000000..0c333d9baf09
--- /dev/null
+++ b/app-misc/fslurp/fslurp-0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fslurp/fslurp-0.7.ebuild,v 1.1 2011/08/11 07:08:30 radhermit Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Read and display data from Fronius IG and IG Plus inverters"
+HOMEPAGE="http://fslurp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake -f makefile CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc History README SampleOutput
+}
diff --git a/app-misc/fslurp/metadata.xml b/app-misc/fslurp/metadata.xml
new file mode 100644
index 000000000000..d588787f530d
--- /dev/null
+++ b/app-misc/fslurp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">
+ fslurp is a program to pull the data from a Fronius Interface Card easy
+ that works with most Fronius IG and IG Plus inverters. It supports both
+ human-readable output and delimited (CSV-style) output.
+ </longdescription>
+</pkgmetadata>