summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-02-26 21:41:23 +0000
committerUlrich Müller <ulm@gentoo.org>2009-02-26 21:41:23 +0000
commitf580e475b1c1ca03405bda3a4aa946315881b86b (patch)
tree461b63ddaf913afba24192d208aecf3d4e7c5576 /app-misc/gcal
parentQA: install usbd.conf only if usb use flag is enabled (diff)
downloadgentoo-2-f580e475b1c1ca03405bda3a4aa946315881b86b.tar.gz
gentoo-2-f580e475b1c1ca03405bda3a4aa946315881b86b.tar.bz2
gentoo-2-f580e475b1c1ca03405bda3a4aa946315881b86b.zip
Change region codes for Germany and Switzerland according to ISO 3166-2,
bug 144813. Specify input file encoding for xgettext. Assign RDEPEND. (Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-misc/gcal')
-rw-r--r--app-misc/gcal/ChangeLog11
-rw-r--r--app-misc/gcal/files/gcal-3.01-gettext-charset.patch11
-rw-r--r--app-misc/gcal/gcal-3.01-r3.ebuild63
3 files changed, 83 insertions, 2 deletions
diff --git a/app-misc/gcal/ChangeLog b/app-misc/gcal/ChangeLog
index 94b0204a8e58..0e1f33416426 100644
--- a/app-misc/gcal/ChangeLog
+++ b/app-misc/gcal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/gcal
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/ChangeLog,v 1.23 2008/09/17 10:12:51 pva Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/ChangeLog,v 1.24 2009/02/26 21:41:23 ulm Exp $
+
+*gcal-3.01-r3 (26 Feb 2009)
+
+ 26 Feb 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/gcal-3.01-gettext-charset.patch, +gcal-3.01-r3.ebuild:
+ Change region codes for Germany and Switzerland according to ISO 3166-2,
+ bug 144813. Specify input file encoding for xgettext. Assign RDEPEND.
17 Sep 2008; Peter Volkov <pva@gentoo.org> gcal-3.01-r2.ebuild:
Fixed glibc-2.8 build issue, bug #227121, thank Evil Compile Person for
diff --git a/app-misc/gcal/files/gcal-3.01-gettext-charset.patch b/app-misc/gcal/files/gcal-3.01-gettext-charset.patch
new file mode 100644
index 000000000000..7a83be20c52f
--- /dev/null
+++ b/app-misc/gcal/files/gcal-3.01-gettext-charset.patch
@@ -0,0 +1,11 @@
+--- gcal-3.01-orig/po/Makefile.in.in 1999-11-08 01:27:46.000000000 +0100
++++ gcal-3.01/po/Makefile.in.in 2009-02-26 10:53:01.000000000 +0100
+@@ -101,7 +101,7 @@
+ $(srcdir)/$(PACKAGE).pot: $(POTFILES)
+ $(XGETTEXT) --default-domain=$(PACKAGE) --directory=$(top_srcdir) \
+ --add-comments --keyword=_ --keyword=N_ \
+- --files-from=$(srcdir)/POTFILES.in \
++ --files-from=$(srcdir)/POTFILES.in --from-code=ISO-8859-1 \
+ && test ! -f $(PACKAGE).po \
+ || ( rm -f $(srcdir)/$(PACKAGE).pot \
+ && mv $(PACKAGE).po $(srcdir)/$(PACKAGE).pot )
diff --git a/app-misc/gcal/gcal-3.01-r3.ebuild b/app-misc/gcal/gcal-3.01-r3.ebuild
new file mode 100644
index 000000000000..73d4bde4bf60
--- /dev/null
+++ b/app-misc/gcal/gcal-3.01-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gcal/gcal-3.01-r3.ebuild,v 1.1 2009/02/26 21:41:23 ulm Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU Calendar - a replacement for cal"
+HOMEPAGE="http://www.gnu.org/software/gcal/gcal.html"
+SRC_URI="mirror://gnu/gcal/${P}.tar.gz
+ mirror://gentoo/${P}-iso3166.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="ncurses nls"
+
+DEPEND="nls? ( >=sys-devel/gettext-0.17 )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-mandir.diff
+ epatch "${FILESDIR}"/${P}-gettext-charset.patch
+ epatch "${WORKDIR}"/${P}-iso3166.patch
+ find -name Makefile.in -print0 | \
+ xargs -0 -n1 sed -i "s:\(^CC = \).*:\1$(tc-getCC):"
+}
+
+src_compile() {
+ append-flags -D_GNU_SOURCE
+ econf $(use_enable nls) $(use_enable ncurses)
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ rm -f "${D}"/usr/share/locale/locale.alias
+
+ dodoc ATTENTION BUGS DISCLAIM HISTORY LIMITATIONS MANIFEST NEWS README \
+ SYMBOLS THANKS TODO
+
+ # Need to fix up paths for scripts in misc directory
+ # that are automatically created by the makefile
+ for miscfile in "${D}"/usr/share/gcal/misc/*/*
+ do
+ dosed "s:${D%/}::g" "${miscfile/${D}}"
+ done
+
+ # Rebuild the symlinks that makefile created into the image /usr/bin
+ # directory during make install
+ dosym /usr/share/gcal/misc/daily/daily /usr/bin/gcal-daily
+ dosym /usr/share/gcal/misc/ddiff/ddiff /usr/bin/gcal-ddiff
+ dosym /usr/share/gcal/misc/ddiff/ddiffdrv /usr/bin/gcal-ddiffdrv
+ dosym /usr/share/gcal/misc/dst/dst /usr/bin/gcal-dst
+ dosym /usr/share/gcal/misc/gcalltx/gcalltx /usr/bin/gcal-gcalltx
+ dosym /usr/share/gcal/misc/gcalltx/gcalltx.pl /usr/bin/gcal-gcalltx.pl
+ dosym /usr/share/gcal/misc/moon/moon /usr/bin/gcal-moon
+ dosym /usr/share/gcal/misc/mrms/mrms /usr/bin/gcal-mrms
+ dosym /usr/share/gcal/misc/srss/srss /usr/bin/gcal-srss
+ dosym /usr/share/gcal/misc/wloc/wlocdrv /usr/bin/gcal-wlocdrv
+}