summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-06-25 09:50:05 +0000
committerFabian Groffen <grobian@gentoo.org>2006-06-25 09:50:05 +0000
commitb5104ee541ea389ef957f99d3579c3e249172bbe (patch)
tree69d715cc19e850d76def4f2b377b9225cbc22573 /app-misc/glimpse/glimpse-4.18.5.ebuild
parentppc stable, bug #137896 (diff)
downloadgentoo-2-b5104ee541ea389ef957f99d3579c3e249172bbe.tar.gz
gentoo-2-b5104ee541ea389ef957f99d3579c3e249172bbe.tar.bz2
gentoo-2-b5104ee541ea389ef957f99d3579c3e249172bbe.zip
Version bump and marked ~ppc-macos (~bug #105876)
(Portage version: 2.1-r1)
Diffstat (limited to 'app-misc/glimpse/glimpse-4.18.5.ebuild')
-rw-r--r--app-misc/glimpse/glimpse-4.18.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/glimpse/glimpse-4.18.5.ebuild b/app-misc/glimpse/glimpse-4.18.5.ebuild
new file mode 100644
index 000000000000..14ed54100e7c
--- /dev/null
+++ b/app-misc/glimpse/glimpse-4.18.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/glimpse-4.18.5.ebuild,v 1.1 2006/06/25 09:50:05 grobian Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A index/query system to search a large set of files quickly"
+HOMEPAGE="http://webglimpse.net/"
+SRC_URI="http://webglimpse.net/trial/${P}.tar.gz"
+
+LICENSE="glimpse"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="static"
+
+RDEPEND="!dev-libs/tre
+ !app-text/agrep
+ virtual/libc"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:CC=.*:CC=$(tc-getCC):" \
+ -e 's:-O3 -fomit-frame-pointer:$(OPTIMIZEFLAGS):' \
+ dynfilters/Makefile.in \
+ || die "removing -O3 failed"
+ sed -i \
+ -e '/^CFLAGS/s:$: $(OPTIMIZEFLAGS):' \
+ {agrep,compress,index}/Makefile.in \
+ Makefile.in \
+ libtemplate/{template,util}/Makefile.in \
+ || die "inserting OPTIMIZEFLAGS failed"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf || die
+ emake -j1 OPTIMIZEFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ einstall || die
+}