summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-06-24 08:05:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-06-24 08:05:08 +0000
commitb243cf8772e54c697677b8b6d8c4f6f00b9b7cdf (patch)
treef01a26a2909e413b3b2771874feb960f100ebb71 /app-misc/gpsdrive
parentVersion bump (diff)
downloadgentoo-2-b243cf8772e54c697677b8b6d8c4f6f00b9b7cdf.tar.gz
gentoo-2-b243cf8772e54c697677b8b6d8c4f6f00b9b7cdf.tar.bz2
gentoo-2-b243cf8772e54c697677b8b6d8c4f6f00b9b7cdf.zip
Version bump to 2.10_pre7
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/gpsdrive')
-rw-r--r--app-misc/gpsdrive/ChangeLog10
-rw-r--r--app-misc/gpsdrive/gpsdrive-2.10_pre7.ebuild109
-rw-r--r--app-misc/gpsdrive/metadata.xml1
3 files changed, 118 insertions, 2 deletions
diff --git a/app-misc/gpsdrive/ChangeLog b/app-misc/gpsdrive/ChangeLog
index 1ee0f01a59ec..9430c458a63d 100644
--- a/app-misc/gpsdrive/ChangeLog
+++ b/app-misc/gpsdrive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/gpsdrive
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gpsdrive/ChangeLog,v 1.30 2008/12/07 20:38:20 nerdboy Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gpsdrive/ChangeLog,v 1.31 2009/06/24 08:05:08 tupone Exp $
+
+*gpsdrive-2.10_pre7 (24 Jun 2009)
+
+ 24 Jun 2009; Alfredo Tupone <tupone@gentoo.org> metadata.xml,
+ +gpsdrive-2.10_pre7.ebuild:
+ Version bump to 2.10_pre7
07 Dec 2008; Steve Arnold <nerdboy@gentoo.org> gpsdrive-2.10_pre5.ebuild:
Updated cmake-utils usage and removed legacy MAKEOPTS value (closes bug
diff --git a/app-misc/gpsdrive/gpsdrive-2.10_pre7.ebuild b/app-misc/gpsdrive/gpsdrive-2.10_pre7.ebuild
new file mode 100644
index 000000000000..26f3c565eddd
--- /dev/null
+++ b/app-misc/gpsdrive/gpsdrive-2.10_pre7.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gpsdrive/gpsdrive-2.10_pre7.ebuild,v 1.1 2009/06/24 08:05:08 tupone Exp $
+EAPI=2
+
+inherit cmake-utils eutils fdo-mime
+
+DESCRIPTION="GPS navigation system with NMEA and Garmin support, zoomable map display, waypoints, etc."
+HOMEPAGE="http://www.gpsdrive.de/"
+SRC_URI="${HOMEPAGE}/packages/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+S=${WORKDIR}/${P/_/}
+
+KEYWORDS="~amd64 ~ppc ~x86"
+# submit bug for ppc64
+
+IUSE="dbus debug libgda gdal mapnik scripts speech"
+
+COMMON_DEP="sci-geosciences/gpsd
+ net-misc/curl
+ dev-libs/libxml2
+ dev-db/sqlite:3
+ x11-libs/gtk+:2
+ dbus? ( dev-libs/dbus-glib )
+ gdal? ( sci-libs/gdal )
+ mapnik? ( sci-geosciences/mapnik )
+ libgda? ( >=gnome-extra/libgda-3.0.1[postgres] )
+ speech? ( app-accessibility/speech-dispatcher )"
+
+DEPEND="${COMMON_DEP}
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEP}
+ sci-geosciences/openstreetmap-icons
+ sci-geosciences/mapnik-world-boundaries
+ media-fonts/dejavu"
+
+src_prepare() {
+ # Update mapnik font path...
+ sed -i \
+ -e "s:truetype/ttf-dejavu:dejavu:g" \
+ -e "s:mapnik/0.5:mapnik:g" \
+ tests/gpsdriverc-in \
+ src/gpsdrive_config.c || die "sed failed"
+ # Fix desktop file...
+ sed -i -e "s:gpsicon:/usr/share/gpsdrive/pixmaps/gpsicon.png:g" \
+ -e "s:Graphics;Network;Geography:Application;Geography;GPS:g" \
+ data/gpsdrive.desktop || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with scripts SCRIPTS)
+ $(cmake-utils_use_with mapnik MAPNIK)
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use_with libgda GDA3)
+ $(cmake-utils_use_with speech SPEECH)
+ $(cmake-utils_use_with gdal GDAL)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS ChangeLog README \
+ Documentation/{CREDITS.i18n,FAQ.gpsdrive,FAQ.gpsdrive.fr,LEEME} \
+ Documentation/{LISEZMOI,NMEA.txt,LISEZMOI.kismet,TODO} \
+ Documentation/README.{Bluetooth,lib_map,nasamaps,tracks,kismet}
+ if use mapnik ; then
+ dodoc Documentation/install-mapnik-osm.txt
+ else
+ rm -f "${D}"usr/bin/gpsdrive_mapnik_gentiles.py
+ rm -f "${D}"usr/share/gpsdrive/osm-template.xml
+ fi
+ if use scripts ; then
+ dodoc Documentation/README.gpspoint2gspdrive
+ if ! use gdal ; then
+ rm -f "${D}"usr/bin/{gdal_slice,nasaconv}.sh
+ fi
+ else
+ rm -f "${D}"usr/share/man/man1/gpsd_nmea.sh.1
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ elog
+ elog "Be sure to see the README files in /usr/share/doc/${PF}"
+ elog "for information on using Kismet with gpsdrive."
+ elog
+ if use mapnik ; then
+ elog "Using mapnik to render online map require you to"
+ elog "load data into the postgis database. Follow instructions"
+ elog "on http://wiki.openstreetmap.org/index.php/Mapnik"
+ fi
+ elog
+ elog "This version also now depends on the gpsd package, and"
+ elog "specific devices are supported there. Start gpsd first,"
+ elog "otherwise gpsdrive will only run in simulation mode (which"
+ elog "is handy for downloading maps for another location, but"
+ elog "not much else)."
+ elog
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-misc/gpsdrive/metadata.xml b/app-misc/gpsdrive/metadata.xml
index a603871aa73c..03941958e45e 100644
--- a/app-misc/gpsdrive/metadata.xml
+++ b/app-misc/gpsdrive/metadata.xml
@@ -12,5 +12,6 @@
<flag name='gdal'>Include gdal and ogr support for format conversions.</flag>
<flag name='mapnik'>Include mapnik support for custom map creation.</flag>
<flag name='scripts'>Include some of the additional helper scripts.</flag>
+ <flag name='speech'>Include speech support.</flag>
</use>
</pkgmetadata>