summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2004-04-02 01:56:19 +0000
committerLars Weiler <pylon@gentoo.org>2004-04-02 01:56:19 +0000
commit5fc9b6b619feca87a6103842ca87b25a52800027 (patch)
tree95f3d815fd0a1de3fa590b498cfa35060573818c /app-misc/gramps/gramps-1.0.1.ebuild
parentfixing Manifest (diff)
downloadgentoo-2-5fc9b6b619feca87a6103842ca87b25a52800027.tar.gz
gentoo-2-5fc9b6b619feca87a6103842ca87b25a52800027.tar.bz2
gentoo-2-5fc9b6b619feca87a6103842ca87b25a52800027.zip
Version bump and reported to be run on ppc (by Aymeric Nys).
Diffstat (limited to 'app-misc/gramps/gramps-1.0.1.ebuild')
-rw-r--r--app-misc/gramps/gramps-1.0.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/gramps/gramps-1.0.1.ebuild b/app-misc/gramps/gramps-1.0.1.ebuild
new file mode 100644
index 000000000000..04b709352ffe
--- /dev/null
+++ b/app-misc/gramps/gramps-1.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/gramps-1.0.1.ebuild,v 1.1 2004/04/02 01:56:19 pylon Exp $
+
+inherit gnome2
+
+IUSE=""
+DESCRIPTION="Genealogical Research and Analysis Management Programming System"
+SRC_URI="mirror://sourceforge/gramps/${P}.tar.gz"
+HOMEPAGE="http://gramps.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+RDEPEND=">=dev-lang/python-2.2
+ >=dev-python/pygtk-1.99.14
+ >=dev-python/gnome-python-1.99.14
+ >=gnome-base/gnome-vfs-2.0
+ >=dev-python/pyxml-0.7.1
+ >=dev-python/Imaging-1.1.3
+ >=dev-python/reportlab-1.11"
+
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ app-text/scrollkeeper"
+
+DOCS="COPYING NEWS README TODO"
+MAKEOPTS="${MAKEOPTS} -j1"
+pkg_setup() {
+ if ! python -c "import gtk.glade" 2>&1 > /dev/null ; then
+ eerror "You need to install pygtk with libglade support. Try:"
+ eerror "USE='gnome' emerge pygtk gramps"
+ die "libglade support missing from pygtk"
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ # fix menu entry location
+ dodir /usr/share/applications
+ mv ${D}/usr/share/gnome/apps/Applications/gramps.desktop \
+ ${D}/usr/share/applications
+ rm -rf ${D}/usr/share/gnome
+}