summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-12-22 12:41:35 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-12-22 12:41:35 +0000
commit19bbf7c3e459e603bcbdf125c5dad5fe3437c453 (patch)
tree4f0a28b34ee09932cbc67a19e08eece7e8271e1a /app-misc/gramps
parentDisable stripping -- this is a binary-only package. (diff)
downloadgentoo-2-19bbf7c3e459e603bcbdf125c5dad5fe3437c453.tar.gz
gentoo-2-19bbf7c3e459e603bcbdf125c5dad5fe3437c453.tar.bz2
gentoo-2-19bbf7c3e459e603bcbdf125c5dad5fe3437c453.zip
fix a race condition for parallel install. Patch provided by flameeyes in bug 249165
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/ChangeLog8
-rw-r--r--app-misc/gramps/files/gramps-3.0.3_fix-installation-race-condition.patch15
-rw-r--r--app-misc/gramps/gramps-3.0.3.ebuild3
3 files changed, 24 insertions, 2 deletions
diff --git a/app-misc/gramps/ChangeLog b/app-misc/gramps/ChangeLog
index 2725e2392f27..23c14b6697e2 100644
--- a/app-misc/gramps/ChangeLog
+++ b/app-misc/gramps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/gramps
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.83 2008/12/13 22:47:13 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.84 2008/12/22 12:41:35 fauli Exp $
+
+ 22 Dec 2008; Christian Faulhammer <fauli@gentoo.org>
+ +files/gramps-3.0.3_fix-installation-race-condition.patch,
+ gramps-3.0.3.ebuild:
+ fix a race condition for parallel install. Patch provided by flameeyes in
+ bug 249165
13 Dec 2008; Friedrich Oslage <bluebird@gentoo.org> gramps-3.0.3.ebuild:
Stable on sparc, bug #249165
diff --git a/app-misc/gramps/files/gramps-3.0.3_fix-installation-race-condition.patch b/app-misc/gramps/files/gramps-3.0.3_fix-installation-race-condition.patch
new file mode 100644
index 000000000000..ed5e5cb487f2
--- /dev/null
+++ b/app-misc/gramps/files/gramps-3.0.3_fix-installation-race-condition.patch
@@ -0,0 +1,15 @@
+--- src/docgen/Makefile.am.orig 2008-12-22 13:24:05.000000000 +0100
++++ src/docgen/Makefile.am 2008-12-22 13:24:39.000000000 +0100
+@@ -23,11 +23,9 @@
+ TextBufDoc.py \
+ GtkPrint.py
+
+-docgen_DATA = \
++dist_docgen_DATA = \
+ gtkprintpreview.glade
+
+-dist_docgen_DATA = $(docgen_DATA)
+-
+ # Clean up all the byte-compiled files
+ MOSTLYCLEANFILES = *pyc *pyo
+
diff --git a/app-misc/gramps/gramps-3.0.3.ebuild b/app-misc/gramps/gramps-3.0.3.ebuild
index 4c663d827a19..8aa759f5d922 100644
--- a/app-misc/gramps/gramps-3.0.3.ebuild
+++ b/app-misc/gramps/gramps-3.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/gramps-3.0.3.ebuild,v 1.6 2008/12/13 22:47:13 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/gramps-3.0.3.ebuild,v 1.7 2008/12/22 12:41:35 fauli Exp $
NEED_PYTHON="2.5"
WANT_AUTOCONF="latest"
@@ -43,6 +43,7 @@ pkg_setup() {
src_unpack() {
gnome2_src_unpack
+ epatch "${FILESDIR}"/${P}_fix-installation-race-condition.patch
eautoreconf
# This is for bug 215944, so .pyo/.pyc files don't get into the
# file system