summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2014-03-22 19:33:59 +0000
committerChristoph Mende <angelos@gentoo.org>2014-03-22 19:33:59 +0000
commit39ef501ecd7b39563cab761dd20950bab8d5e7e8 (patch)
tree936dbf5e1465fe8729fe7ad8caf7ff1259db550c /app-misc/granule
parentRemove old. (diff)
downloadgentoo-2-39ef501ecd7b39563cab761dd20950bab8d5e7e8.tar.gz
gentoo-2-39ef501ecd7b39563cab761dd20950bab8d5e7e8.tar.bz2
gentoo-2-39ef501ecd7b39563cab761dd20950bab8d5e7e8.zip
Import patch from debian to fix compilation with gcc4.8
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 84F20B43)
Diffstat (limited to 'app-misc/granule')
-rw-r--r--app-misc/granule/ChangeLog9
-rw-r--r--app-misc/granule/files/granule-1.4.0-fix-template-with-permissive.patch15
-rw-r--r--app-misc/granule/granule-1.4.0.ebuild9
3 files changed, 28 insertions, 5 deletions
diff --git a/app-misc/granule/ChangeLog b/app-misc/granule/ChangeLog
index 1c68dac74a95..6b89b33337fa 100644
--- a/app-misc/granule/ChangeLog
+++ b/app-misc/granule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/granule
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/granule/ChangeLog,v 1.11 2012/05/03 19:41:35 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/granule/ChangeLog,v 1.12 2014/03/22 19:33:59 angelos Exp $
+
+ 22 Mar 2014; Christoph Mende <angelos@gentoo.org>
+ +files/granule-1.4.0-fix-template-with-permissive.patch, granule-1.4.0.ebuild:
+ Import patch from debian to fix compilation with gcc4.8
03 May 2012; Jeff Horelick <jdhore@gentoo.org> granule-1.4.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -40,4 +44,3 @@
11 Sep 2007; Christoph Mende <angelos@gentoo.org> +granule-1.2.4.ebuild:
Initial import
-
diff --git a/app-misc/granule/files/granule-1.4.0-fix-template-with-permissive.patch b/app-misc/granule/files/granule-1.4.0-fix-template-with-permissive.patch
new file mode 100644
index 000000000000..252c41e77973
--- /dev/null
+++ b/app-misc/granule/files/granule-1.4.0-fix-template-with-permissive.patch
@@ -0,0 +1,15 @@
+Description: Fix build with gcc4.8 and -fpermissive
+Bug-Debian: http://bugs.debian.org/701292
+Last-Update: 2013-08-11
+
+--- granule-1.4.0-7.orig/src/Granule.cpp
++++ granule-1.4.0-7/src/Granule.cpp
+@@ -56,7 +56,7 @@ ASSA_DECL_SINGLETON(Granule);
+
+ static const int TIMEOUT = 2000; // 2 seconds (1,000 mls = 1 sec).
+
+-template <> xmlExternalEntityLoader Granule::m_default_entity_loader = 0;
++xmlExternalEntityLoader Granule::m_default_entity_loader = 0;
+
+ /*******************************************************************************
+ Member Functions
diff --git a/app-misc/granule/granule-1.4.0.ebuild b/app-misc/granule/granule-1.4.0.ebuild
index 356f5493e341..9fa3b74a2938 100644
--- a/app-misc/granule/granule-1.4.0.ebuild
+++ b/app-misc/granule/granule-1.4.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/granule/granule-1.4.0.ebuild,v 1.6 2012/05/03 19:41:35 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/granule/granule-1.4.0.ebuild,v 1.7 2014/03/22 19:33:59 angelos Exp $
EAPI="2"
+inherit eutils
DESCRIPTION="A flashcard program that implements Leitner cardfile methodology"
HOMEPAGE="http://granule.sourceforge.net/"
@@ -28,6 +29,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P}-7"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-template-with-permissive.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README