summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-10 17:25:33 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-10 17:25:33 +0000
commit85e3aa014e579303d3959c909536de98ec5258a6 (patch)
tree7981f4bc67c887f91904e8618bfafc14d01a95f9 /app-misc/graphlcd-base
parentversion bump (diff)
downloadgentoo-2-85e3aa014e579303d3959c909536de98ec5258a6.tar.gz
gentoo-2-85e3aa014e579303d3959c909536de98ec5258a6.tar.bz2
gentoo-2-85e3aa014e579303d3959c909536de98ec5258a6.zip
Apply patch from Peter Alfredsen <loki_val@gentoo.org> to respect LDFLAGS. Bug #227163
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/graphlcd-base')
-rw-r--r--app-misc/graphlcd-base/ChangeLog11
-rw-r--r--app-misc/graphlcd-base/files/graphlcd-base-0.1.5-ldflags.patch232
-rw-r--r--app-misc/graphlcd-base/graphlcd-base-0.1.5-r2.ebuild45
3 files changed, 286 insertions, 2 deletions
diff --git a/app-misc/graphlcd-base/ChangeLog b/app-misc/graphlcd-base/ChangeLog
index 4c924f7d13f6..c3e1e6880e1f 100644
--- a/app-misc/graphlcd-base/ChangeLog
+++ b/app-misc/graphlcd-base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/graphlcd-base
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/graphlcd-base/ChangeLog,v 1.22 2009/02/01 22:03:34 hd_brummy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/graphlcd-base/ChangeLog,v 1.23 2010/08/10 17:25:32 hwoarang Exp $
+
+*graphlcd-base-0.1.5-r2 (10 Aug 2010)
+
+ 10 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +graphlcd-base-0.1.5-r2.ebuild, +files/graphlcd-base-0.1.5-ldflags.patch:
+ Apply patch from Peter Alfredsen <loki_val@gentoo.org> to respect LDFLAGS.
+ Bug #227163
01 Feb 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
graphlcd-base-0.1.5-r1.ebuild:
diff --git a/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-ldflags.patch b/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-ldflags.patch
new file mode 100644
index 000000000000..25f90248bc3c
--- /dev/null
+++ b/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-ldflags.patch
@@ -0,0 +1,232 @@
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/Makefile graphlcd-base-0.1.5/glcddrivers/Makefile
+--- graphlcd-base-0.1.5.orig/glcddrivers/Makefile 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/Makefile 2008-06-15 14:15:29.000000000 +0200
+@@ -20,11 +20,11 @@
+
+
+ ### Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c $(DEFINES) $(INCLUDES) $<
+
+ # Dependencies:
+
+ MAKEDEP = g++ -MM -MG
+ DEPFILE = .dependencies
+@@ -36,11 +36,11 @@
+ ### Targets:
+
+ all: $(LIBNAME)
+
+ $(LIBNAME): $(OBJS)
+- $(CXX) $(CXXFLAGS) -shared $(OBJS) $(LIBS) -ldl -lpthread -Wl,-soname="$(BASENAME).$(VERMAJOR)" -o $@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) $(LIBS) -ldl -lpthread -Wl,-soname="$(BASENAME).$(VERMAJOR)" -o $@
+ ln -sf $(LIBNAME) $(BASENAME)
+
+ install: all
+ install -d $(LIBDIR)
+ install -m 755 $(LIBNAME) $(LIBDIR)/
+diff -NrU5 graphlcd-base-0.1.5.orig/glcdgraphics/Makefile graphlcd-base-0.1.5/glcdgraphics/Makefile
+--- graphlcd-base-0.1.5.orig/glcdgraphics/Makefile 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcdgraphics/Makefile 2008-06-15 14:16:07.000000000 +0200
+@@ -19,11 +19,11 @@
+ HEADERS = bitmap.h font.h glcd.h image.h imagefile.h pbm.h
+
+ ### Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c $(DEFINES) $(INCLUDES) $<
+
+ # Dependencies:
+
+ MAKEDEP = g++ -MM -MG
+ DEPFILE = .dependencies
+@@ -44,11 +44,11 @@
+ endif### Targets:
+
+ all: $(LIBNAME)
+
+ $(LIBNAME): $(OBJS)
+- $(CXX) $(CXXFLAGS) -shared $(OBJS) $(LIBS) -Wl,-soname="$(BASENAME).$(VERMAJOR)" -o $@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) $(LIBS) -Wl,-soname="$(BASENAME).$(VERMAJOR)" -o $@
+ ln -sf $(LIBNAME) $(BASENAME)
+
+ install: all
+ install -d $(LIBDIR)
+ install -m 755 $(LIBNAME) $(LIBDIR)/
+diff -NrU5 graphlcd-base-0.1.5.orig/tools/convpic/Makefile graphlcd-base-0.1.5/tools/convpic/Makefile
+--- graphlcd-base-0.1.5.orig/tools/convpic/Makefile 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/tools/convpic/Makefile 2008-06-15 14:16:32.000000000 +0200
+@@ -16,11 +16,11 @@
+ .PHONY: all
+
+ # Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c $(DEFINES) $(INCLUDES) $<
+
+ # Dependencies:
+
+ MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+@@ -30,11 +30,11 @@
+ -include $(DEPFILE)
+
+ # The main program:
+
+ $(PRGNAME): $(OBJS)
+- $(CXX) $(CXXFLAGS) -rdynamic $(OBJS) $(LIBS) $(LIBDIRS) -lglcdgraphics -lstdc++ -o $(PRGNAME)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -rdynamic $(OBJS) $(LIBS) $(LIBDIRS) -lglcdgraphics -lstdc++ -o $(PRGNAME)
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+diff -NrU5 graphlcd-base-0.1.5.orig/tools/crtfont/Makefile graphlcd-base-0.1.5/tools/crtfont/Makefile
+--- graphlcd-base-0.1.5.orig/tools/crtfont/Makefile 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/tools/crtfont/Makefile 2008-06-15 14:18:28.000000000 +0200
+@@ -15,11 +15,11 @@
+ .PHONY: all
+
+ # Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c $(DEFINES) $(INCLUDES) $<
+
+ # Dependencies:
+
+ MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+@@ -40,11 +40,11 @@
+ endif### Targets:
+
+ # The main program:
+
+ $(PRGNAME): $(OBJS)
+- $(CXX) $(CXXFLAGS) -rdynamic $(OBJS) $(LIBDIRS) -lglcdgraphics -lstdc++ -o $(PRGNAME)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -rdynamic $(OBJS) $(LIBDIRS) -lglcdgraphics -lstdc++ -o $(PRGNAME)
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+diff -NrU5 graphlcd-base-0.1.5.orig/tools/genfont/Makefile graphlcd-base-0.1.5/tools/genfont/Makefile
+--- graphlcd-base-0.1.5.orig/tools/genfont/Makefile 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/tools/genfont/Makefile 2008-06-15 14:18:46.000000000 +0200
+@@ -18,11 +18,11 @@
+ .PHONY: all
+
+ # Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c $(DEFINES) $(INCLUDES) $<
+
+ # Dependencies:
+
+ MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+@@ -32,11 +32,11 @@
+ -include $(DEPFILE)
+
+ # The main program:
+
+ $(PRGNAME): $(OBJS)
+- $(CXX) $(CXXFLAGS) -rdynamic $(OBJS) $(LIBDIRS) $(LIBS) -lglcdgraphics -lstdc++ -o $(PRGNAME)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -rdynamic $(OBJS) $(LIBDIRS) $(LIBS) -lglcdgraphics -lstdc++ -o $(PRGNAME)
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+diff -NrU5 graphlcd-base-0.1.5.orig/tools/lcdtestpattern/Makefile graphlcd-base-0.1.5/tools/lcdtestpattern/Makefile
+--- graphlcd-base-0.1.5.orig/tools/lcdtestpattern/Makefile 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/tools/lcdtestpattern/Makefile 2008-06-15 14:19:08.000000000 +0200
+@@ -16,11 +16,11 @@
+ .PHONY: all
+
+ # Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c $(DEFINES) $(INCLUDES) $<
+
+ # Dependencies:
+
+ MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+@@ -41,11 +41,11 @@
+ endif### Targets:
+
+ # The main program:
+
+ $(PRGNAME): $(OBJS)
+- $(CXX) $(CXXFLAGS) -rdynamic $(OBJS) $(LIBS) $(LIBDIRS) -lglcdgraphics -lglcddrivers -lstdc++ -o $(PRGNAME)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -rdynamic $(OBJS) $(LIBS) $(LIBDIRS) -lglcdgraphics -lglcddrivers -lstdc++ -o $(PRGNAME)
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+diff -NrU5 graphlcd-base-0.1.5.orig/tools/showpic/Makefile graphlcd-base-0.1.5/tools/showpic/Makefile
+--- graphlcd-base-0.1.5.orig/tools/showpic/Makefile 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/tools/showpic/Makefile 2008-06-15 14:19:29.000000000 +0200
+@@ -16,11 +16,11 @@
+ .PHONY: all
+
+ # Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c $(DEFINES) $(INCLUDES) $<
+
+ # Dependencies:
+
+ MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+@@ -41,11 +41,11 @@
+ endif### Targets:
+
+ # The main program:
+
+ $(PRGNAME): $(OBJS)
+- $(CXX) $(CXXFLAGS) -rdynamic $(OBJS) $(LIBS) $(LIBDIRS) -lglcdgraphics -lglcddrivers -lstdc++ -o $(PRGNAME)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -rdynamic $(OBJS) $(LIBS) $(LIBDIRS) -lglcdgraphics -lglcddrivers -lstdc++ -o $(PRGNAME)
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+diff -NrU5 graphlcd-base-0.1.5.orig/tools/showtext/Makefile graphlcd-base-0.1.5/tools/showtext/Makefile
+--- graphlcd-base-0.1.5.orig/tools/showtext/Makefile 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/tools/showtext/Makefile 2008-06-15 14:23:52.000000000 +0200
+@@ -16,11 +16,11 @@
+ .PHONY: all
+
+ # Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c $(DEFINES) $(INCLUDES) $<
+
+ # Dependencies:
+
+ MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+@@ -41,11 +41,11 @@
+ endif### Targets:
+
+ # The main program:
+
+ $(PRGNAME): $(OBJS)
+- $(CXX) $(CXXFLAGS) -rdynamic $(OBJS) $(LIBS) $(LIBDIRS) -lglcdgraphics -lglcddrivers -lstdc++ -o $(PRGNAME)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -rdynamic $(OBJS) $(LIBS) $(LIBDIRS) -lglcdgraphics -lglcddrivers -lstdc++ -o $(PRGNAME)
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
diff --git a/app-misc/graphlcd-base/graphlcd-base-0.1.5-r2.ebuild b/app-misc/graphlcd-base/graphlcd-base-0.1.5-r2.ebuild
new file mode 100644
index 000000000000..e7852e3172fe
--- /dev/null
+++ b/app-misc/graphlcd-base/graphlcd-base-0.1.5-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/graphlcd-base/graphlcd-base-0.1.5-r2.ebuild,v 1.1 2010/08/10 17:25:32 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Graphical LCD Driver"
+HOMEPAGE="http://graphlcd.berlios.de/"
+SRC_URI="mirror://berlios/graphlcd/${P}.tgz
+ mirror://vdrfiles/${PN}/${P}_utf8.diff.tgz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="truetype unicode g15"
+
+DEPEND=""
+
+RDEPEND="truetype? ( media-libs/freetype media-fonts/corefonts )
+ unicode? ( media-libs/freetype media-fonts/corefonts )
+ g15? ( app-misc/g15daemon )"
+
+src_prepare() {
+ sed -i Make.config -e "s:usr\/local:usr:" -e "s:FLAGS *=:FLAGS ?=:"
+ epatch "${FILESDIR}/${P}-nostrip.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+
+ use !truetype && sed -i "s:HAVE_FREETYPE2:#HAVE_FREETYPE2:" Make.config
+
+ use unicode && epatch "${WORKDIR}/${P}_utf8.diff" && \
+ sed -i "s:#HAVE_FREETYPE2:HAVE_FREETYPE2:" Make.config
+}
+
+src_install() {
+
+ make DESTDIR="${D}"/usr LIBDIR="${D}"/usr/$(get_libdir) install || die "make install failed"
+
+ insinto /etc
+ doins graphlcd.conf
+
+ dodoc docs/*
+}