summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2004-06-24 22:51:54 +0000
committerHanno Böck <hanno@gentoo.org>2004-06-24 22:51:54 +0000
commitb545fcf0283726979aaec8f730578c09260caef1 (patch)
tree3722fa67b22cf8a06ca3746d88859e4e6b801ae3 /app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild
parent(Manifest recommit) (diff)
downloadgentoo-2-b545fcf0283726979aaec8f730578c09260caef1.tar.gz
gentoo-2-b545fcf0283726979aaec8f730578c09260caef1.tar.bz2
gentoo-2-b545fcf0283726979aaec8f730578c09260caef1.zip
fixed ktoblzcheck ebuild
Diffstat (limited to 'app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild')
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild
new file mode 100644
index 000000000000..0a99f7b74387
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-0.7-r1.ebuild,v 1.1 2004/06/24 22:51:54 hanno Exp $
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ktoblzcheck/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ sys-apps/gawk
+ sys-apps/grep
+ sys-devel/libtool
+ sys-devel/gcc"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall BANKDATA_PATH="${D}/usr/share/ktoblzcheck" || die
+}
+
+src_test() {
+ cd ${S}/src/bin/
+ ./check_ktoblzcheck || die "self check of accounts failed"
+}