summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-10-17 04:12:03 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-10-17 04:12:03 +0000
commitf8fc287f78543aa004c29a5f50e81ea0694b5986 (patch)
tree3fe24ba51427ab828f660f4c1616f210965c2bf2 /app-misc/leave/leave-20041016.ebuild
parentAdded ewarn; bug #50510. (Manifest recommit) (diff)
downloadgentoo-2-f8fc287f78543aa004c29a5f50e81ea0694b5986.tar.gz
gentoo-2-f8fc287f78543aa004c29a5f50e81ea0694b5986.tar.bz2
gentoo-2-f8fc287f78543aa004c29a5f50e81ea0694b5986.zip
Initial commit.
Diffstat (limited to 'app-misc/leave/leave-20041016.ebuild')
-rw-r--r--app-misc/leave/leave-20041016.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/leave/leave-20041016.ebuild b/app-misc/leave/leave-20041016.ebuild
new file mode 100644
index 000000000000..79e55bcb9d1e
--- /dev/null
+++ b/app-misc/leave/leave-20041016.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/leave/leave-20041016.ebuild,v 1.1 2004/10/17 04:12:03 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="Command-line tool from FreeBSD that reminds you when its time to leave"
+HOMEPAGE="http://www.freebsd.org/cgi/cvsweb.cgi/src/usr.bin/leave/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-fix-makefile.diff
+}
+
+src_compile() {
+ emake \
+ CC="${CC:-gcc}" \
+ CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin leave
+ doman leave.1
+ dodoc ${FILESDIR}/README
+}