summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2007-01-22 23:48:11 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2007-01-22 23:48:11 +0000
commitf54cd7a3e3e567826d461fd0a5f769fce4da7423 (patch)
treee96e98b7683a16e725d4312feda7cca90beed1cb /app-misc/nut/nut-12.2.ebuild
parentAdd ~ia64 keyword. (diff)
downloadgentoo-2-f54cd7a3e3e567826d461fd0a5f769fce4da7423.tar.gz
gentoo-2-f54cd7a3e3e567826d461fd0a5f769fce4da7423.tar.bz2
gentoo-2-f54cd7a3e3e567826d461fd0a5f769fce4da7423.zip
Bump to nut-12.2, bug 123755. Thanks to Michael Vogt for the ebuild
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'app-misc/nut/nut-12.2.ebuild')
-rw-r--r--app-misc/nut/nut-12.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/nut/nut-12.2.ebuild b/app-misc/nut/nut-12.2.ebuild
new file mode 100644
index 000000000000..dce1c016dc16
--- /dev/null
+++ b/app-misc/nut/nut-12.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-12.2.ebuild,v 1.1 2007/01/22 23:48:11 masterdriverz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://www.lafn.org/~av832/"
+SRC_URI="http://www.lafn.org/~av832/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ append-flags '-DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/share/nut\"'
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/nut
+ insinto /usr/share/nut
+ doins raw.data/*
+ dobin nut
+ doman nut.1
+}