summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-22 12:48:15 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-22 12:48:15 +0000
commita93343f6cc821e8230978fe031a790f1f7b601a5 (patch)
treec7aa4969e00c1934d6bc0500c47e6298e0a1f943 /app-misc/relevation/relevation-1.3.ebuild
parentBump to EAPI=5 (diff)
downloadgentoo-2-a93343f6cc821e8230978fe031a790f1f7b601a5.tar.gz
gentoo-2-a93343f6cc821e8230978fe031a790f1f7b601a5.tar.bz2
gentoo-2-a93343f6cc821e8230978fe031a790f1f7b601a5.zip
Initial import.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-misc/relevation/relevation-1.3.ebuild')
-rw-r--r--app-misc/relevation/relevation-1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/relevation/relevation-1.3.ebuild b/app-misc/relevation/relevation-1.3.ebuild
new file mode 100644
index 000000000000..ea1254fca7f6
--- /dev/null
+++ b/app-misc/relevation/relevation-1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/relevation/relevation-1.3.ebuild,v 1.1 2014/06/22 12:48:15 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="a command-line searcher for the Revelation password manager"
+HOMEPAGE="http://p.outlyer.net/relevation/"
+SRC_URI="http://p.outlyer.net/${PN}/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # install extra scripts in proper doc dir
+ sed -i "s#relevation/extra#${PF}/extra#" setup.py || die
+
+ distutils-r1_python_prepare_all
+}