summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-02-14 13:41:54 +0000
committerHanno Böck <hanno@gentoo.org>2008-02-14 13:41:54 +0000
commitace0120edba4d89fc3eabbb71246ed807e4f6a76 (patch)
tree27ba5c157aa23aaa2c0d32e8619eb1ebdf569264 /app-misc/sdricoh_cs
parentStable for HPPA (bug #209465). (diff)
downloadgentoo-2-ace0120edba4d89fc3eabbb71246ed807e4f6a76.tar.gz
gentoo-2-ace0120edba4d89fc3eabbb71246ed807e4f6a76.tar.bz2
gentoo-2-ace0120edba4d89fc3eabbb71246ed807e4f6a76.zip
sdricoh_cs: update for 2.6.24 (should still work with older kernels)
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc/sdricoh_cs')
-rw-r--r--app-misc/sdricoh_cs/ChangeLog10
-rw-r--r--app-misc/sdricoh_cs/files/sdricoh_cs-2.6.24.diff11
-rw-r--r--app-misc/sdricoh_cs/sdricoh_cs-0.1.2-r1.ebuild25
-rw-r--r--app-misc/sdricoh_cs/sdricoh_cs-0.1.2.ebuild4
4 files changed, 46 insertions, 4 deletions
diff --git a/app-misc/sdricoh_cs/ChangeLog b/app-misc/sdricoh_cs/ChangeLog
index e65e22d223ea..2bac6ba8d189 100644
--- a/app-misc/sdricoh_cs/ChangeLog
+++ b/app-misc/sdricoh_cs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/sdricoh_cs
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sdricoh_cs/ChangeLog,v 1.3 2007/11/24 14:09:15 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sdricoh_cs/ChangeLog,v 1.4 2008/02/14 13:41:53 hanno Exp $
+
+*sdricoh_cs-0.1.2-r1 (14 Feb 2008)
+
+ 14 Feb 2008; Hanno Boeck <hanno@gentoo.org> +files/sdricoh_cs-2.6.24.diff,
+ +sdricoh_cs-0.1.2-r1.ebuild:
+ Fix for kernel 2.6.24.
24 Nov 2007; Samuli Suominen <drac@gentoo.org> sdricoh_cs-0.1.2.ebuild:
Keyword ~amd64 wrt #200180.
diff --git a/app-misc/sdricoh_cs/files/sdricoh_cs-2.6.24.diff b/app-misc/sdricoh_cs/files/sdricoh_cs-2.6.24.diff
new file mode 100644
index 000000000000..4933581bf17b
--- /dev/null
+++ b/app-misc/sdricoh_cs/files/sdricoh_cs-2.6.24.diff
@@ -0,0 +1,11 @@
+--- sdricoh_cs-0.1.2/sdricoh_cs.c 2007-11-21 17:47:16.000000000 +0100
++++ sdricoh_cs-0.1.2-1/sdricoh_cs.c 2008-01-28 16:06:03.000000000 +0100
+@@ -369,7 +369,7 @@
+ /* special command handling */
+ /* FIXME */
+ if (cmd->opcode == MMC_SELECT_CARD) {
+- if(host->mode == MMC_MODE_SD){
++ if(host->mode == MODE_SD){
+ sdricoh_mmc_cmd(host, MMC_APP_CMD, cmd->arg); /* what is this for? set bus_width?*/
+ sdricoh_mmc_cmd(host, 0x46, 0x02);
+ }else{
diff --git a/app-misc/sdricoh_cs/sdricoh_cs-0.1.2-r1.ebuild b/app-misc/sdricoh_cs/sdricoh_cs-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..0e7e0fbbc71b
--- /dev/null
+++ b/app-misc/sdricoh_cs/sdricoh_cs-0.1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sdricoh_cs/sdricoh_cs-0.1.2-r1.ebuild,v 1.1 2008/02/14 13:41:53 hanno Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Driver for Ricoh Bay1Controller found in some laptops"
+HOMEPAGE="http://sdricohcs.sourceforge.net"
+SRC_URI="mirror://sourceforge/sdricohcs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+CONFIG_CHECK="MMC_BLOCK"
+MODULE_NAMES="sdricoh_cs(mmc:)"
+ERROR_MMC_BLOCK="${P} requires MMC block device support (CONFIG_MMC_BLOCK)."
+MODULESD_SDRICOH_CS_DOCS="ChangeLog README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/sdricoh_cs-2.6.24.diff" || die "epatch failed"
+}
diff --git a/app-misc/sdricoh_cs/sdricoh_cs-0.1.2.ebuild b/app-misc/sdricoh_cs/sdricoh_cs-0.1.2.ebuild
index 3d39e39cd582..42dd6e7b25a3 100644
--- a/app-misc/sdricoh_cs/sdricoh_cs-0.1.2.ebuild
+++ b/app-misc/sdricoh_cs/sdricoh_cs-0.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sdricoh_cs/sdricoh_cs-0.1.2.ebuild,v 1.2 2007/11/24 14:09:15 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sdricoh_cs/sdricoh_cs-0.1.2.ebuild,v 1.3 2008/02/14 13:41:53 hanno Exp $
inherit linux-mod