summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2004-06-18 11:09:19 +0000
committerChristian Andreetta <satya@gentoo.org>2004-06-18 11:09:19 +0000
commit5f8329e154cfdcd7d6a0cc055e4688dcb92cacba (patch)
tree642d49c8202384f0fef74c9abf5bb179327961cd /app-misc/smbc/smbc-0.8.0.ebuild
parent~ppc update (Manifest recommit) (diff)
downloadgentoo-2-5f8329e154cfdcd7d6a0cc055e4688dcb92cacba.tar.gz
gentoo-2-5f8329e154cfdcd7d6a0cc055e4688dcb92cacba.tar.bz2
gentoo-2-5f8329e154cfdcd7d6a0cc055e4688dcb92cacba.zip
new ebuild. bug #44624
Diffstat (limited to 'app-misc/smbc/smbc-0.8.0.ebuild')
-rw-r--r--app-misc/smbc/smbc-0.8.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/smbc/smbc-0.8.0.ebuild b/app-misc/smbc/smbc-0.8.0.ebuild
new file mode 100644
index 000000000000..349b9cfa8d34
--- /dev/null
+++ b/app-misc/smbc/smbc-0.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/smbc/smbc-0.8.0.ebuild,v 1.1 2004/06/18 11:09:18 satya Exp $
+
+inherit eutils
+
+DESCRIPTION="Text mode SMB network commander"
+HOMEPAGE="http://www.air.rzeszow.pl/smbc/smbc/en/"
+SRC_URI="http://www.air.rzeszow.pl/${PN}/${PN}/${PV}/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls debug"
+DEPEND=">=samba-3.0.1
+ >=sys-devel/automake-1.8
+ dev-libs/popt
+ sys-libs/ncurses
+ nls? ( sys-devel/gettext )"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e s:\/doc\/\":\/doc\/${PF}\/\": doc/Makefile.in \
+ || die "Unpack failed"
+}
+
+src_compile() {
+ local myconf
+
+ use nls \
+ && myconf="${myconf} `use_enable nls`" \
+ || myconf="${myconf} `use_enable nls`"
+ use debug \
+ && myconf="${myconf} `use_with debug`"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ChangeLog
+ prepalldocs
+}