summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2008-11-10 00:33:05 +0000
committerGordon Malm <gengor@gentoo.org>2008-11-10 00:33:05 +0000
commit928e6d034fd8675f5b25a6c81aa32d5dc21f5107 (patch)
tree4a9b62c2e88fb3345cc4225c5527cd04e4be81ee /app-misc/sphinx
parentVersion bump (diff)
downloadgentoo-2-928e6d034fd8675f5b25a6c81aa32d5dc21f5107.tar.gz
gentoo-2-928e6d034fd8675f5b25a6c81aa32d5dc21f5107.tar.bz2
gentoo-2-928e6d034fd8675f5b25a6c81aa32d5dc21f5107.zip
Version bump to 0.9.8.1 and redigest for libstemmer_c.tgz
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog8
-rw-r--r--app-misc/sphinx/sphinx-0.9.8.1.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 32c70db5ac7a..3a10226dbfa4 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.14 2008/10/25 20:27:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.15 2008/11/10 00:33:05 gengor Exp $
+
+*sphinx-0.9.8.1 (10 Nov 2008)
+
+ 10 Nov 2008; Gordon Malm <gengor@gentoo.org> +sphinx-0.9.8.1.ebuild:
+ Version bump on behalf of Caleb. Redigest libstemmer_c.tgz, it doesn't match
+ the mirrors.
25 Oct 2008; Caleb Tennis <caleb@gentoo.org> sphinx-0.9.8.ebuild:
amd64 stable
diff --git a/app-misc/sphinx/sphinx-0.9.8.1.ebuild b/app-misc/sphinx/sphinx-0.9.8.1.ebuild
new file mode 100644
index 000000000000..8650492f5602
--- /dev/null
+++ b/app-misc/sphinx/sphinx-0.9.8.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.8.1.ebuild,v 1.1 2008/11/10 00:33:05 gengor Exp $
+
+inherit eutils autotools
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz
+ stemmer? ( http://snowball.tartarus.org/dist/libstemmer_c.tgz )"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug mysql postgres stemmer test"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )"
+RDEPEND="${DEPEND}
+ test? ( dev-lang/php )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use stemmer; then
+ cd "${S}"
+ unpack libstemmer_c.tgz
+ fi
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with stemmer libstemmer) \
+ $(use_with debug) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc doc/* example.sql
+ dodir /etc/sphinx
+ insinto /etc/sphinx
+ doins sphinx.conf.dist
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+ dodir /var/run/sphinx
+}