summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-11-10 07:54:57 +0000
committerFabian Groffen <grobian@gentoo.org>2010-11-10 07:54:57 +0000
commitc5f282888f94b3c0dcf4cd6fe87884f5c738d21d (patch)
tree5e171042e6f443e06eab9c39d126c22d91d0c199 /app-misc/sphinx
parentRemove p.mask entries for www-client/chromium-bin, it's reasonably tested now. (diff)
downloadgentoo-2-c5f282888f94b3c0dcf4cd6fe87884f5c738d21d.tar.gz
gentoo-2-c5f282888f94b3c0dcf4cd6fe87884f5c738d21d.tar.bz2
gentoo-2-c5f282888f94b3c0dcf4cd6fe87884f5c738d21d.zip
Fix building on Darwin for both versions with libsphinxclient, keyword 1.10_beta appropriately now it builds
(Portage version: 2.2.01.17168-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog8
-rw-r--r--app-misc/sphinx/files/sphinx-1.10_beta-darwin8.patch23
-rw-r--r--app-misc/sphinx/files/sphinx-1.10_beta-libsphinxclient-darwin.patch22
-rw-r--r--app-misc/sphinx/sphinx-0.9.9-r2.ebuild5
-rw-r--r--app-misc/sphinx/sphinx-1.10_beta-r1.ebuild6
5 files changed, 60 insertions, 4 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 78c5606ddad3..96078151a5aa 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.31 2010/11/09 20:31:01 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.32 2010/11/10 07:54:57 grobian Exp $
+
+ 10 Nov 2010; Fabian Groffen <grobian@gentoo.org> sphinx-0.9.9-r2.ebuild,
+ sphinx-1.10_beta-r1.ebuild, +files/sphinx-1.10_beta-darwin8.patch,
+ +files/sphinx-1.10_beta-libsphinxclient-darwin.patch:
+ Fix building on Darwin for both versions with libsphinxclient, keyword
+ 1.10_beta appropriately now it builds
*sphinx-1.10_beta-r1 (09 Nov 2010)
*sphinx-0.9.9-r2 (09 Nov 2010)
diff --git a/app-misc/sphinx/files/sphinx-1.10_beta-darwin8.patch b/app-misc/sphinx/files/sphinx-1.10_beta-darwin8.patch
new file mode 100644
index 000000000000..73ddd556d76d
--- /dev/null
+++ b/app-misc/sphinx/files/sphinx-1.10_beta-darwin8.patch
@@ -0,0 +1,23 @@
+Darwin8 has no backtrace functionalities yet
+
+--- src/searchd.cpp
++++ src/searchd.cpp
+@@ -1291,6 +1291,10 @@
+ __asm __volatile__ ( "movq %%rbp,%0":"=r"(pFramePointer):"r"(pFramePointer) );
+ #endif
+
++#ifndef SIGRETURN_FRAME_OFFSET
++ sphLogFatal ( "Cannot get stack frame pointer on this architecture" );
++#else
++
+ if ( !pFramePointer )
+ {
+ sphLogFatal ( "Frame pointer is null. Unable to backtrace the stack. Did you build the searchd with -fomit-frame-pointer?" );
+@@ -1329,6 +1333,7 @@
+ if ( !bOk )
+ sphWarning ( "Something wrong in frame pointers. BackTrace failed (failed FP was %p)", pNewFP );
+ else
++#endif
+ #endif // !HAVE_BACKTRACE
+ sphInfo ( "Stack trace seems to be succesfull. Now you have to resolve the numbers above and attach resolved values to the bugreport. See the section about resolving in the documentation" );
+
diff --git a/app-misc/sphinx/files/sphinx-1.10_beta-libsphinxclient-darwin.patch b/app-misc/sphinx/files/sphinx-1.10_beta-libsphinxclient-darwin.patch
new file mode 100644
index 000000000000..594b7351e121
--- /dev/null
+++ b/app-misc/sphinx/files/sphinx-1.10_beta-libsphinxclient-darwin.patch
@@ -0,0 +1,22 @@
+On Darwin, the linker doesn't like it when vsnprintf is prefixed by an
+underscore. This obviously is an error, since it's only necessary for
+Windows. Add an extra guard, such that vsnprintf is left alone.
+
+--- api/libsphinxclient/sphinxclient.c
++++ api/libsphinxclient/sphinxclient.c
+@@ -13,6 +13,7 @@
+ // did not, you can find it at http://www.gnu.org/
+ //
+
++#if defined(_MSC_VER)
+ #if _MSC_VER>=1400
+ // VS 2005 and above
+ #define _CRT_SECURE_NO_DEPRECATE 1
+@@ -21,6 +22,7 @@
+ // VS 2003 and below
+ #define vsnprintf _vsnprintf
+ #endif
++#endif
+
+ #include <stdlib.h>
+ #include <stdarg.h>
diff --git a/app-misc/sphinx/sphinx-0.9.9-r2.ebuild b/app-misc/sphinx/sphinx-0.9.9-r2.ebuild
index 379742a6a6d6..d28f5cee21a7 100644
--- a/app-misc/sphinx/sphinx-0.9.9-r2.ebuild
+++ b/app-misc/sphinx/sphinx-0.9.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.9-r2.ebuild,v 1.1 2010/11/09 20:31:01 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.9-r2.ebuild,v 1.2 2010/11/10 07:54:57 grobian Exp $
EAPI=3
inherit eutils autotools
@@ -46,6 +46,9 @@ src_prepare() {
api/libsphinxclient/sphinxclient.c || die
eautoreconf
+
+ cd api/libsphinxclient || die
+ eautoreconf
}
src_configure() {
diff --git a/app-misc/sphinx/sphinx-1.10_beta-r1.ebuild b/app-misc/sphinx/sphinx-1.10_beta-r1.ebuild
index ebaf2c2c7ad3..59ffba4f0f19 100644
--- a/app-misc/sphinx/sphinx-1.10_beta-r1.ebuild
+++ b/app-misc/sphinx/sphinx-1.10_beta-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-1.10_beta-r1.ebuild,v 1.1 2010/11/09 20:31:01 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-1.10_beta-r1.ebuild,v 1.2 2010/11/10 07:54:57 grobian Exp $
EAPI=3
inherit eutils autotools
@@ -18,7 +18,7 @@ SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos"
IUSE="debug id64 mysql odbc postgres stemmer test"
RDEPEND="mysql? ( virtual/mysql )
@@ -43,6 +43,8 @@ src_prepare() {
sed -i -e '/\/usr\/local\//d' configure.ac || die
epatch "${FILESDIR}"/${P}-nosigpipe.patch
+ epatch "${FILESDIR}"/${P}-darwin8.patch
+ epatch "${FILESDIR}"/${P}-libsphinxclient-darwin.patch
eautoreconf