summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-22 22:04:50 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-22 22:04:50 +0000
commitf2078abd33e79d9f065f78b3bc39ede43f018498 (patch)
treedee93731c31c734d3fe0a92ea339bc5e669de629 /app-misc/sphinx
parentSwitch ebuild to EAPI-2. (diff)
downloadgentoo-2-f2078abd33e79d9f065f78b3bc39ede43f018498.tar.gz
gentoo-2-f2078abd33e79d9f065f78b3bc39ede43f018498.tar.bz2
gentoo-2-f2078abd33e79d9f065f78b3bc39ede43f018498.zip
No action for a couple of months on this bug #276252. libstemmer mirrored to Gentoo systems now with a version number. revbump so that all existing users can converge on having an identical libstemmer.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog10
-rw-r--r--app-misc/sphinx/sphinx-0.9.9_rc2-r2.ebuild66
2 files changed, 75 insertions, 1 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 1f6beafcaf62..1743994ea9e1 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.19 2009/11/05 15:41:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.20 2009/11/22 22:04:50 robbat2 Exp $
+
+*sphinx-0.9.9_rc2-r2 (22 Nov 2009)
+
+ 22 Nov 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +sphinx-0.9.9_rc2-r2.ebuild:
+ No action for a couple of months on this bug #276252. libstemmer mirrored
+ to Gentoo systems now with a version number. revbump so that all
+ existing users can converge on having an identical libstemmer.
*sphinx-0.9.9_rc2-r1 (26 Sep 2009)
diff --git a/app-misc/sphinx/sphinx-0.9.9_rc2-r2.ebuild b/app-misc/sphinx/sphinx-0.9.9_rc2-r2.ebuild
new file mode 100644
index 000000000000..c96c17c5705d
--- /dev/null
+++ b/app-misc/sphinx/sphinx-0.9.9_rc2-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.9_rc2-r2.ebuild,v 1.1 2009/11/22 22:04:50 robbat2 Exp $
+
+EAPI=2
+inherit eutils autotools
+
+MY_P=${P/_/-}
+
+# This has been added by Gentoo, to explicitly version libstemmer.
+# It is the date that http://snowball.tartarus.org/dist/libstemmer_c.tgz was
+# fetched.
+STEMMER_PV="20091122"
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz
+ stemmer? ( mirror://gentoo/libstemmer_c-${STEMMER_PV}.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug id64 mysql postgres stemmer test"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )"
+RDEPEND="${DEPEND}
+ test? ( dev-lang/php )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use stemmer; then
+ cd "${S}"
+ unpack libstemmer_c-${STEMMER_PV}.tgz
+ fi
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with stemmer libstemmer)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc doc/*
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+ dodir /var/run/sphinx
+
+ newinitd "${FILESDIR}"/searchd.rc searchd
+}