summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-18 20:38:39 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-18 20:38:39 +0000
commit8422a7ecdb655e19c4854018a8d2375af0fd5c3b (patch)
treea3f00125534274690d75711986846b3b72951eb9 /app-misc/strigi
parentneeds freetype-2 (diff)
downloadgentoo-2-8422a7ecdb655e19c4854018a8d2375af0fd5c3b.tar.gz
gentoo-2-8422a7ecdb655e19c4854018a8d2375af0fd5c3b.tar.bz2
gentoo-2-8422a7ecdb655e19c4854018a8d2375af0fd5c3b.zip
Old.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc/strigi')
-rw-r--r--app-misc/strigi/ChangeLog5
-rw-r--r--app-misc/strigi/strigi-0.5.7.ebuild100
2 files changed, 4 insertions, 101 deletions
diff --git a/app-misc/strigi/ChangeLog b/app-misc/strigi/ChangeLog
index a428e1703a4e..71705b646f9b 100644
--- a/app-misc/strigi/ChangeLog
+++ b/app-misc/strigi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/strigi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.2 2008/03/10 21:49:04 zlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.3 2008/03/18 20:38:39 ingmar Exp $
+
+ 18 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org> -strigi-0.5.7.ebuild:
+ Old.
*strigi-0.5.8 (10 Mar 2008)
diff --git a/app-misc/strigi/strigi-0.5.7.ebuild b/app-misc/strigi/strigi-0.5.7.ebuild
deleted file mode 100644
index 749fe6aebd3f..000000000000
--- a/app-misc/strigi/strigi-0.5.7.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.5.7.ebuild,v 1.1 2008/01/13 18:18:23 philantrop Exp $
-
-EAPI="1"
-inherit eutils cmake-utils
-
-DESCRIPTION="Fast crawling desktop search engine with Qt4 GUI"
-HOMEPAGE="http://www.vandenoever.info/software/strigi"
-SRC_URI="http://www.vandenoever.info/software/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+clucene +dbus +exiv2 debug hyperestraier java inotify +qt4 test"
-# log sqlite
-RESTRICT="test"
-
-COMMONDEPEND="
- dev-libs/libxml2
- virtual/libiconv
- clucene? ( >=dev-cpp/clucene-0.9.16a )
- dbus? ( sys-apps/dbus )
- exiv2? ( media-gfx/exiv2 )
- hyperestraier? ( app-text/hyperestraier )
- java? (
- >=dev-libs/xerces-c-2.7.0-r1
- >=virtual/jdk-1.4
- )
- qt4? ( >=x11-libs/qt-4.2.1-r1 )"
-# log? ( >=dev-libs/log4cxx-0.9.7 )
-# sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${COMMONDEPEND}
- test? ( dev-util/cppunit )"
-RDEPEND="${COMMONDEPEND}"
-
-pkg_setup() {
- # & ! use sqlite
- if ! use clucene && ! use hyperestraier; then
- echo ""
- ewarn "It's highly recommended to enable one of the supported backends:"
- ewarn "clucene, hyperestraier and sqlite3"
- ewarn "Clucene is currently the recommended backend."
- ewarn "Without a backend you'll only be able to use deepgrep."
- echo ""
- fi
-
- if use dbus && use qt4 && ! built_with_use x11-libs/qt:4 dbus; then
- echo ""
- eerror "You are building Strigi with qt4 and dbus, but qt4 wasn't built with dbus support."
- eerror "Please re-emerge qt4 with dbus, or disable dbus in Strigi."
- echo ""
- die
- fi
-
- if use qt4 && ! use dbus; then
- echo ""
- eerror "You are building Strigi with qt4 but without dbus."
- eerror "Strigiclient needs dbus to detect a running Strigi daemon."
- eerror "Please enable both qt4 and dbus."
- echo ""
- die
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-automagic-deps.patch"
-}
-
-src_compile() {
- # Strigi needs either expat or libxml2.
- # However libxml2 seems to be required in both cases, linking to 2 xml parsers is
- # just silly, so we forcefully disable linking to expat.
-
- # Disabled: NEWXESAM (targetted at developers)
-
- # Enabled: POLLING (only reliable way to check for files changed.)
-
- mycmakeargs="${mycmakeargs}
- -DENABLE_EXPAT=OFF -DENABLE_NEWXESAM=OFF -DENABLE_POLLING=ON
- -DFORCE_DEPS=ON -DENABLE_CPPUNIT=OFF
- $(cmake-utils_use_enable clucene CLUCENE)
- $(cmake-utils_use_enable dbus DBUS)
- $(cmake-utils_use_enable exiv2 EXIV2)
- $(cmake-utils_use_enable hyperestraier HYPERESTRAIER)
- $(cmake-utils_use_enable inotify INOTIFY)
- $(cmake-utils_use_enable qt4 QT4)"
- # $(cmake-utils_use_enable log LOG4CXX)
- # $(cmake-utils_use_enable sqlite SQLITE)
- cmake-utils_src_compile
-}
-
-src_test() {
- mycmakeargs="${mycmakeargs} -DENABLE_CPPUNIT=ON"
- cmake-utils_src_compile -j1
- ctest --extra-verbose || die "Tests failed."
-}