summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-08-04 09:52:28 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-08-04 09:52:28 +0000
commit4566785a1584c8c8ff1b811f3a4ea29e8fea62ff (patch)
tree884d6fc7d83a4d58782dc5308cda22d0ddf0530d /app-misc/tdl
parentinitial import (diff)
downloadgentoo-2-4566785a1584c8c8ff1b811f3a4ea29e8fea62ff.tar.gz
gentoo-2-4566785a1584c8c8ff1b811f3a4ea29e8fea62ff.tar.bz2
gentoo-2-4566785a1584c8c8ff1b811f3a4ea29e8fea62ff.zip
initial import
Diffstat (limited to 'app-misc/tdl')
-rw-r--r--app-misc/tdl/ChangeLog9
-rw-r--r--app-misc/tdl/Manifest3
-rw-r--r--app-misc/tdl/files/digest-tdl-1.4.11
-rw-r--r--app-misc/tdl/tdl-1.4.1.ebuild61
4 files changed, 73 insertions, 1 deletions
diff --git a/app-misc/tdl/ChangeLog b/app-misc/tdl/ChangeLog
new file mode 100644
index 000000000000..061f5dec4b80
--- /dev/null
+++ b/app-misc/tdl/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-misc/tdl
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/ChangeLog,v 1.1 2003/08/04 09:52:20 taviso Exp $
+
+*tdl-1.4.1 (04 Aug 2003)
+
+ 04 Aug 2003; Tavis Ormandy <taviso@gentoo.org> tdl-1.4.1.ebuild:
+ Initial import.
+
diff --git a/app-misc/tdl/Manifest b/app-misc/tdl/Manifest
index b1a9f2d2f35e..7375ed9e9a4b 100644
--- a/app-misc/tdl/Manifest
+++ b/app-misc/tdl/Manifest
@@ -1,2 +1,3 @@
-MD5 d0df43c9bcccb943e943339e4bcd4c44 tdl-1.4.1.ebuild 1237
+MD5 029307031dffecf64a704b2d415cbed8 tdl-1.4.1.ebuild 1348
+MD5 e0ee5bc2032f7825630b5602fcd9b6c3 ChangeLog 318
MD5 e99939886dd2c94f740140ef76236e33 files/digest-tdl-1.4.1 60
diff --git a/app-misc/tdl/files/digest-tdl-1.4.1 b/app-misc/tdl/files/digest-tdl-1.4.1
new file mode 100644
index 000000000000..79c78392b9b1
--- /dev/null
+++ b/app-misc/tdl/files/digest-tdl-1.4.1
@@ -0,0 +1 @@
+MD5 298b5ac103e6d3cadfdbcd046a6745a9 tdl-1.4.1.tar.gz 65292
diff --git a/app-misc/tdl/tdl-1.4.1.ebuild b/app-misc/tdl/tdl-1.4.1.ebuild
new file mode 100644
index 000000000000..11dda7d3f7bd
--- /dev/null
+++ b/app-misc/tdl/tdl-1.4.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.4.1.ebuild,v 1.1 2003/08/04 09:52:20 taviso Exp $
+
+DESCRIPTION="Command line To Do List manager"
+HOMEPAGE="http://www.rc0.org.uk/tdl/"
+SRC_URI="http://www.rrbcurnow.freeuk.com/tdl/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="readline ncurses doc"
+
+RDEPEND="readline? ( >=sys-libs/readline-4.3
+ ncurses? ( sys-libs/ncurses )
+ !ncurses? ( sys-libs/libtermcap-compat ) )
+ doc? ( app-text/tetex )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf="--prefix=/usr"
+
+ if ! use readline; then
+ myconf="${myconf} --without-readline"
+ else
+ if use ncurses; then
+ sed -i 's#-ltermcap#-lncurses#g' ${S}/configure
+ else
+ sed -i 's#-lncurses##g' ${S}/configure
+ fi
+ fi
+
+ ./configure ${myconf} || die "configure failed, sorry!"
+ emake all tdl.info tdl.html tdl.txt || die
+ use doc && emake tdl.dvi tdl.ps tdl.pdf
+}
+
+src_install() {
+ local i
+
+ dodoc COPYING README NEWS
+ doinfo tdl.info
+ dohtml tdl.html
+
+ dobin tdl
+ doman tdl.1
+
+ for i in tdl{a,l,d,g}
+ do
+ dosym tdl /usr/bin/${i}
+ dosym tdl.1 /usr/share/man/man1/${i}.1
+ done
+
+ prepallman
+
+ use doc && dodoc tdl.dvi tdl.ps tdl.pdf
+}