summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2013-11-15 13:19:13 +0000
committerAlex Alexander <wired@gentoo.org>2013-11-15 13:19:13 +0000
commit27b36b7990688da3d7079cecdb9092d9e437445d (patch)
tree633bb26e9a45767c705f180e9e1fa701ba57b151 /app-misc/tmux-mem-cpu-load
parentversion bump, bug #489574 (diff)
downloadgentoo-2-27b36b7990688da3d7079cecdb9092d9e437445d.tar.gz
gentoo-2-27b36b7990688da3d7079cecdb9092d9e437445d.tar.bz2
gentoo-2-27b36b7990688da3d7079cecdb9092d9e437445d.zip
migrated to git-2, removed obsolete src_prepare, added live ebuild
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'app-misc/tmux-mem-cpu-load')
-rw-r--r--app-misc/tmux-mem-cpu-load/ChangeLog8
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild13
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild29
3 files changed, 38 insertions, 12 deletions
diff --git a/app-misc/tmux-mem-cpu-load/ChangeLog b/app-misc/tmux-mem-cpu-load/ChangeLog
index 330223c65e2c..07a794084910 100644
--- a/app-misc/tmux-mem-cpu-load/ChangeLog
+++ b/app-misc/tmux-mem-cpu-load/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/tmux-mem-cpu-load
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux-mem-cpu-load/ChangeLog,v 1.5 2013/11/15 13:14:37 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux-mem-cpu-load/ChangeLog,v 1.6 2013/11/15 13:19:12 wired Exp $
+
+*tmux-mem-cpu-load-9999 (15 Nov 2013)
+
+ 15 Nov 2013; Alex Alexander <wired@gentoo.org>
+ tmux-mem-cpu-load-2.2.1.ebuild, +tmux-mem-cpu-load-9999.ebuild:
+ migrated to git-2, removed obsolete src_prepare, added live ebuild
*tmux-mem-cpu-load-2.2.1 (15 Nov 2013)
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild
index bd80fca07e3c..0821df4dc9dd 100644
--- a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild,v 1.1 2013/11/15 13:14:37 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild,v 1.2 2013/11/15 13:19:13 wired Exp $
EAPI="3"
@@ -8,7 +8,7 @@ inherit cmake-utils
IUSE=""
if [[ ${PV} == *9999* ]]; then
- inherit git
+ inherit git-2
EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/thewtex/tmux-mem-cpu-load.git"}
KEYWORDS=""
SRC_URI=""
@@ -23,15 +23,6 @@ HOMEPAGE="http://github.com/thewtex/tmux-mem-cpu-load/"
LICENSE="Apache-2.0"
SLOT="0"
-src_prepare() {
- if [[ ${PV} == *9999* ]]; then
- git_src_prepare
- else
- cd "${WORKDIR}"/thewtex-${PN}-*
- S=$(pwd)
- fi
-}
-
src_install() {
cmake-utils_src_install
dodoc README.rst || die
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild
new file mode 100644
index 000000000000..9bc8a3eb77f3
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild,v 1.1 2013/11/15 13:19:13 wired Exp $
+
+EAPI="3"
+
+inherit cmake-utils
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/thewtex/tmux-mem-cpu-load.git"}
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/thewtex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"
+HOMEPAGE="http://github.com/thewtex/tmux-mem-cpu-load/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.rst || die
+}