summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago Cunha <tcunha@gentoo.org>2009-09-20 23:21:10 +0000
committerTiago Cunha <tcunha@gentoo.org>2009-09-20 23:21:10 +0000
commitc4ff803b0afea56211df9872479293b8638f4c1e (patch)
tree0411c1a38d8041a230e77a23f49f23dafd90028d /app-misc/tmux/tmux-1.0.ebuild
parentFix tests, bug 285698 (diff)
downloadgentoo-2-c4ff803b0afea56211df9872479293b8638f4c1e.tar.gz
gentoo-2-c4ff803b0afea56211df9872479293b8638f4c1e.tar.bz2
gentoo-2-c4ff803b0afea56211df9872479293b8638f4c1e.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/tmux/tmux-1.0.ebuild')
-rw-r--r--app-misc/tmux/tmux-1.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/tmux/tmux-1.0.ebuild b/app-misc/tmux/tmux-1.0.ebuild
new file mode 100644
index 000000000000..c614afa19e3b
--- /dev/null
+++ b/app-misc/tmux/tmux-1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.0.ebuild,v 1.1 2009/09/20 23:21:10 tcunha Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="vim-syntax? ( || (
+ app-editors/gvim
+ app-editors/vim ) )"
+
+src_compile() {
+ # The configure script isn't created by GNU autotools.
+ ./configure || die "configure failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin tmux || die "dobin failed"
+
+ dodoc CHANGES FAQ NOTES TODO || die "dodoc failed"
+ docinto examples
+ dodoc examples/*.{conf,sh} || die "dodoc examples failed"
+
+ doman tmux.1 || die "doman failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim || die "doins syntax failed"
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim || die "doins ftdetect failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "If you want to use tmux as your login shell, don't forget to add"
+ elog "it to the list of valid shells in the /etc/shells file."
+}