summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-01 08:25:08 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-01 08:25:08 +0000
commit8c4feb81319963a9e33706bd1b0d8e2547aa7246 (patch)
treeb51ce21ace6df4bf6a34e78389f14fd8fc680f97 /app-misc/tmux/tmux-9999.ebuild
parentInitial import. (diff)
downloadgentoo-2-8c4feb81319963a9e33706bd1b0d8e2547aa7246.tar.gz
gentoo-2-8c4feb81319963a9e33706bd1b0d8e2547aa7246.tar.bz2
gentoo-2-8c4feb81319963a9e33706bd1b0d8e2547aa7246.zip
Upstream now uses autotools, #350261
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/tmux/tmux-9999.ebuild')
-rw-r--r--app-misc/tmux/tmux-9999.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index 34d39cb6e324..196048720b73 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-9999.ebuild,v 1.1 2010/10/28 20:55:42 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-9999.ebuild,v 1.2 2011/01/01 08:25:08 jlec Exp $
EAPI=3
ECVS_SERVER="tmux.cvs.sourceforge.net:/cvsroot/tmux"
ECVS_MODULE="tmux"
-inherit cvs toolchain-funcs
+inherit autotools cvs
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="http://tmux.sourceforge.net"
@@ -16,35 +16,34 @@ SRC_URI=""
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="vim-syntax"
+IUSE="debug vim-syntax"
-DEPEND="<dev-libs/libevent-2
+DEPEND="
+ <dev-libs/libevent-2
sys-libs/ncurses"
RDEPEND="${DEPEND}
vim-syntax? ( || (
app-editors/vim
app-editors/gvim ) )"
-S="${WORKDIR}"/"${PN}"
+S="${WORKDIR}"/${PN}
-src_configure() {
- # The configure script isn't created by GNU autotools.
- ./configure || die "configure failed"
+src_prepare() {
+ eautoreconf
}
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+src_configure() {
+ econf \
+ $(use_enable debug)
}
src_install() {
- dobin tmux || die "dobin failed"
+ emake DESTDIR="${D}" install || die
dodoc CHANGES FAQ NOTES TODO || die "dodoc failed"
docinto examples
dodoc examples/*.conf || die "dodoc examples failed"
- doman tmux.1 || die "doman failed"
-
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
doins examples/tmux.vim || die "doins syntax failed"