summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-08 15:12:29 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-08 15:12:29 +0000
commit2cce8a756dd73be380bf13766472b83a0fbd13e9 (patch)
tree67bab119458570ffba8d87311c2c72c8cdc28636 /app-misc/tmux
parentapp-misc/grc: Add support for ipv6, #450324; use python-r1.eclass (diff)
downloadgentoo-2-2cce8a756dd73be380bf13766472b83a0fbd13e9.tar.gz
gentoo-2-2cce8a756dd73be380bf13766472b83a0fbd13e9.tar.bz2
gentoo-2-2cce8a756dd73be380bf13766472b83a0fbd13e9.zip
app-misc/tmux: Install bashcompletion file, #450896
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/ChangeLog10
-rw-r--r--app-misc/tmux/metadata.xml12
-rw-r--r--app-misc/tmux/tmux-1.6.ebuild8
-rw-r--r--app-misc/tmux/tmux-1.7-r1.ebuild66
-rw-r--r--app-misc/tmux/tmux-1.7.ebuild8
-rw-r--r--app-misc/tmux/tmux-9999.ebuild8
6 files changed, 97 insertions, 15 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index 81545ae4524e..34089822cce7 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/tmux
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.87 2012/12/28 17:58:30 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.88 2013/01/08 15:12:29 jlec Exp $
+
+*tmux-1.7-r1 (08 Jan 2013)
+
+ 08 Jan 2013; Justin Lecher <jlec@gentoo.org> tmux-1.6.ebuild,
+ tmux-1.7.ebuild, +tmux-1.7-r1.ebuild, tmux-9999.ebuild, metadata.xml:
+ Install bashcompletion file, #450896
28 Dec 2012; Jeroen Roovers <jer@gentoo.org> tmux-1.7.ebuild:
Stable for HPPA (bug #449000).
diff --git a/app-misc/tmux/metadata.xml b/app-misc/tmux/metadata.xml
index 293ae1e3988c..a88ed84b3bba 100644
--- a/app-misc/tmux/metadata.xml
+++ b/app-misc/tmux/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>shell-tools</herd>
- <maintainer>
- <email>wired@gentoo.org</email>
- <name>Alex Alexander</name>
- </maintainer>
- <longdescription>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>wired@gentoo.org</email>
+ <name>Alex Alexander</name>
+ </maintainer>
+ <longdescription>
tmux is a "terminal multiplexer", it enables a number of terminals
(or windows) to be accessed and controlled from a single terminal.
tmux is intended to be a simple, modern, BSD-licensed alternative to
diff --git a/app-misc/tmux/tmux-1.6.ebuild b/app-misc/tmux/tmux-1.6.ebuild
index 7e47646fdef8..3efef5fa0104 100644
--- a/app-misc/tmux/tmux-1.6.ebuild
+++ b/app-misc/tmux/tmux-1.6.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.6.ebuild,v 1.9 2012/10/13 17:23:16 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.6.ebuild,v 1.10 2013/01/08 15:12:29 jlec Exp $
EAPI=4
+inherit bash-completion-r1
+
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="http://tmux.sourceforge.net"
SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
@@ -58,6 +60,8 @@ src_prepare() {
src_install() {
default
+ newbashcomp examples/bash_completion_tmux.sh ${PN}
+
docinto examples
dodoc examples/*.conf
diff --git a/app-misc/tmux/tmux-1.7-r1.ebuild b/app-misc/tmux/tmux-1.7-r1.ebuild
new file mode 100644
index 000000000000..6f3b23ace857
--- /dev/null
+++ b/app-misc/tmux/tmux-1.7-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.7-r1.ebuild,v 1.1 2013/01/08 15:12:29 jlec Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="vim-syntax"
+
+COMMON_DEPEND="
+ >=dev-libs/libevent-2.0.10
+ sys-libs/ncurses"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+DOCS=( CHANGES FAQ NOTES TODO )
+
+pkg_setup() {
+ if has_version "<app-misc/tmux-1.7"; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: after updating to ${P} you will _not_ be able to connect to any"
+ ewarn "running 1.6 tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to tmux 1.6 to access them."
+ echo
+ fi
+}
+
+src_prepare() {
+ # look for config file in the prefix
+ sed -i -e '/SYSTEM_CFG/s:"/etc:"'"${EPREFIX}"'/etc:' tmux.h || die
+ # and don't just add some includes
+ sed -i -e 's:-I/usr/local/include::' Makefile.in || die
+}
+
+src_install() {
+ default
+
+ newbashcomp examples/bash_completion_tmux.sh ${PN}
+
+ docinto examples
+ dodoc examples/*.conf
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim
+ fi
+}
diff --git a/app-misc/tmux/tmux-1.7.ebuild b/app-misc/tmux/tmux-1.7.ebuild
index d9c36a4f8d2f..42ea55f3b20d 100644
--- a/app-misc/tmux/tmux-1.7.ebuild
+++ b/app-misc/tmux/tmux-1.7.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.7.ebuild,v 1.3 2012/12/28 17:58:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.7.ebuild,v 1.4 2013/01/08 15:12:29 jlec Exp $
EAPI=4
+inherit bash-completion-r1
+
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="http://tmux.sourceforge.net"
SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
@@ -49,6 +51,8 @@ src_prepare() {
src_install() {
default
+ newbashcomp examples/bash_completion_tmux.sh ${PN}
+
docinto examples
dodoc examples/*.conf
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index 8bce0eec35b8..4dceae6a4bf2 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-9999.ebuild,v 1.6 2012/10/13 17:34:20 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-9999.ebuild,v 1.7 2013/01/08 15:12:29 jlec Exp $
EAPI=4
-inherit autotools git-2
+inherit autotools git-2 bash-completion-r1
EGIT_REPO_URI="git://tmux.git.sourceforge.net/gitroot/tmux/tmux"
@@ -44,6 +44,8 @@ src_configure() {
src_install() {
default
+ newbashcomp examples/bash_completion_tmux.sh ${PN}
+
docinto examples
dodoc examples/*.conf