summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-07-30 18:01:53 +0000
committerSven Wegener <swegener@gentoo.org>2008-07-30 18:01:53 +0000
commita142104b36a42318371f3cad1c0ed6675dbcf93d (patch)
tree3d45d8dcddb2c37ef6211e3f62dd871e5c175d32 /app-misc/tmux
parentBump iceweasel icons tarball (diff)
downloadgentoo-2-a142104b36a42318371f3cad1c0ed6675dbcf93d.tar.gz
gentoo-2-a142104b36a42318371f3cad1c0ed6675dbcf93d.tar.bz2
gentoo-2-a142104b36a42318371f3cad1c0ed6675dbcf93d.zip
Initial commit from the sunrise overlay. I'm going to proxy-maintain this for Tiago Cunha <me@tiagocunha.org>.
(Portage version: 2.2_rc5/cvs/Linux 2.6.27-rc1 x86_64)
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/ChangeLog11
-rw-r--r--app-misc/tmux/Manifest4
-rw-r--r--app-misc/tmux/metadata.xml9
-rw-r--r--app-misc/tmux/tmux-0.4a.ebuild36
4 files changed, 60 insertions, 0 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
new file mode 100644
index 000000000000..660ff6cec23b
--- /dev/null
+++ b/app-misc/tmux/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-misc/tmux
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.1 2008/07/30 18:01:53 swegener Exp $
+
+*tmux-0.4a (30 Jul 2008)
+
+ 30 Jul 2008; Sven Wegener <swegener@gentoo.org> +metadata.xml,
+ +tmux-0.4a.ebuild:
+ Initial commit from the sunrise overlay. I'm going to proxy-maintain this
+ for Tiago Cunha <me@tiagocunha.org>.
+
diff --git a/app-misc/tmux/Manifest b/app-misc/tmux/Manifest
new file mode 100644
index 000000000000..3ec6b9b9392d
--- /dev/null
+++ b/app-misc/tmux/Manifest
@@ -0,0 +1,4 @@
+DIST tmux-0.4a.tar.gz 100685 RMD160 cd6df6c07a195abbf03f55039922922d5bb7661f SHA1 9713d6902559af49c1b4344cefebe1b09da4bfaa SHA256 2aebe1161a7ac6563e5b2dda502da49d52c9e4059ba5cea1b21c6fc703d8bc78
+EBUILD tmux-0.4a.ebuild 777 RMD160 a3c6f62c9fd7b746366dc07a52af7c9be9dd5081 SHA1 e020ae17936e8af237fa64766911f2cb6558e735 SHA256 8e2af0b949adc50f43c717563ce7445465ff46d1c6252589d63568dd412767c2
+MISC ChangeLog 342 RMD160 cc8b77c748b37f7ee9ad1cd1b5d89e618ee9c1ab SHA1 c0752ae547c1374fc966721b66fcf763889ad7fe SHA256 b1e0bc32f85deda84ec83ed84e6b538e70293dfe7ee77fcbfa21800338282ddb
+MISC metadata.xml 308 RMD160 bd9a21e44f31c2296f1e65da8578e8d33d67f929 SHA1 a6c27fdc5d1546a5d3e4126bcbf77c336c93aa9b SHA256 92afb9d973d29bc70bcaa2a86914ec88c8d37627c66ce435ed3af15ce2acdeae
diff --git a/app-misc/tmux/metadata.xml b/app-misc/tmux/metadata.xml
new file mode 100644
index 000000000000..950120c0c24e
--- /dev/null
+++ b/app-misc/tmux/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>shell-tools</herd>
+<maintainer>
+ <email>swegener@gentoo.org</email>
+ <description>Proxy maintainer for Tiago Cunha (me@tiagocunha.org)</description>
+</maintainer>
+</pkgmetadata>
diff --git a/app-misc/tmux/tmux-0.4a.ebuild b/app-misc/tmux/tmux-0.4a.ebuild
new file mode 100644
index 000000000000..badd36a887e4
--- /dev/null
+++ b/app-misc/tmux/tmux-0.4a.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-0.4a.ebuild,v 1.1 2008/07/30 18:01:53 swegener Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, modern, alternative to programs such as GNU screen"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake DEBUG="" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin tmux || die "dobin tmux failed"
+
+ dodoc NOTES TODO
+ docinto examples
+ dodoc examples/*.conf
+
+ doman tmux.1
+}
+
+pkg_postinst() {
+ elog "NOTE that tmux doesn't support \\\033_string\\\033\\\\\\ for window"
+ elog "titles. If you're using BASH unset PROMPT_COMMAND."
+}