summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-03 14:22:17 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-03 14:22:17 +0000
commit9029c7b62b2e362e548e84646599197107444da1 (patch)
tree9d36427dfecaccf62e17eab8832bda5a5757712e /app-misc/wcd/wcd-5.1.4.ebuild
parentMasking zen-sources snapshot release (diff)
downloadgentoo-2-9029c7b62b2e362e548e84646599197107444da1.tar.gz
gentoo-2-9029c7b62b2e362e548e84646599197107444da1.tar.bz2
gentoo-2-9029c7b62b2e362e548e84646599197107444da1.zip
New addition, written by me
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/wcd/wcd-5.1.4.ebuild')
-rw-r--r--app-misc/wcd/wcd-5.1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/wcd/wcd-5.1.4.ebuild b/app-misc/wcd/wcd-5.1.4.ebuild
new file mode 100644
index 000000000000..32c523a76a9e
--- /dev/null
+++ b/app-misc/wcd/wcd-5.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wcd/wcd-5.1.4.ebuild,v 1.1 2011/03/03 14:22:17 jlec Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Wherever Change Directory"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/#WCD_ANCHOR"
+SRC_URI="http://www.xs4all.nl/~waterlan/${P}-src.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="ncurses nls unicode"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CC
+}
+
+src_compile() {
+ local mycompile
+ use nls || mycompile="${mycompile} ENABLE_NLS="
+ use ncurses || mycompile="${mycompile} CURSES="
+ use unicode && mycompile="${mycompile} UCS=1"
+ emake \
+ ${mycompile} \
+ || die
+}