summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-19 03:56:16 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-19 03:56:16 +0000
commitdbf6bea79084651d5fc69c5702d1f411eb36e3d4 (patch)
tree5ffc1c3c7b6170b3b67510d5d53817a39c729ff1 /app-misc/wipe
parentAdd ~amd64-linux, ~x86-linux keywords (diff)
downloadgentoo-2-dbf6bea79084651d5fc69c5702d1f411eb36e3d4.tar.gz
gentoo-2-dbf6bea79084651d5fc69c5702d1f411eb36e3d4.tar.bz2
gentoo-2-dbf6bea79084651d5fc69c5702d1f411eb36e3d4.zip
Respect LDFLAGS (bug #337251), CFLAGS.
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'app-misc/wipe')
-rw-r--r--app-misc/wipe/ChangeLog10
-rw-r--r--app-misc/wipe/files/wipe-2.2.20050509-gentoo.patch106
-rw-r--r--app-misc/wipe/wipe-2.2.20050509-r1.ebuild43
3 files changed, 157 insertions, 2 deletions
diff --git a/app-misc/wipe/ChangeLog b/app-misc/wipe/ChangeLog
index 733c6754137c..186dee6979d1 100644
--- a/app-misc/wipe/ChangeLog
+++ b/app-misc/wipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/wipe
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/ChangeLog,v 1.23 2009/12/06 03:52:44 jsbronder Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/ChangeLog,v 1.24 2010/09/19 03:56:16 jer Exp $
+
+*wipe-2.2.20050509-r1 (19 Sep 2010)
+
+ 19 Sep 2010; Jeroen Roovers <jer@gentoo.org> +wipe-2.2.20050509-r1.ebuild,
+ +files/wipe-2.2.20050509-gentoo.patch:
+ Respect LDFLAGS (bug #337251), CFLAGS.
06 Dec 2009; Justin Bronder <jsbronder@gentoo.org>
wipe-2.2.20050509.ebuild:
diff --git a/app-misc/wipe/files/wipe-2.2.20050509-gentoo.patch b/app-misc/wipe/files/wipe-2.2.20050509-gentoo.patch
new file mode 100644
index 000000000000..2519118e2f5e
--- /dev/null
+++ b/app-misc/wipe/files/wipe-2.2.20050509-gentoo.patch
@@ -0,0 +1,106 @@
+* Get rid of a lot of compiler flag cruft
+* Respect LDFLAGS and CFLAGS
+
+--- a/configure.in 2004-11-28 00:47:52.000000000 +0100
++++ b/configure.in 2010-09-19 05:49:48.000000000 +0200
+@@ -14,12 +14,7 @@
+ bin=wipe
+
+ fullCFLAGS=""
+-wallCFLAGS=""
+-pendanticCFLAGS=""
+-tempCFLAGS=""
+-temp2CFLAGS=""
+-checkCFLAGS=""
+-optCFLAGS=""
++optCFLAGS="${CFLAGS}"
+ #CFLAGS="-g -Wall -Werror -ansi -pedantic -O2 -finline-functions -ffast-math -fomit-frame-pointer"
+
+ AC_CANONICAL_SYSTEM
+@@ -34,65 +29,9 @@
+ AC_PROG_INSTALL
+
+ dnl Compilation tests
+-AC_MSG_CHECKING([whether the C compiler accepts -pipe])
+-CFLAGS="-pipe"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); tempCFLAGS="$CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_MSG_CHECKING([whether the C compiler accepts -g])
+-CFLAGS="-g"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); debugCFLAGS="$CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_MSG_CHECKING([whether the C compiler accepts -O0])
+-CFLAGS="-O0"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); debugCFLAGS="$debugCFLAGS $CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_MSG_CHECKING([whether the C compiler accepts -O2])
+-CFLAGS="-O2"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); tempCFLAGS="$tempCFLAGS $CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_MSG_CHECKING([whether the C compiler accepts -ansi])
+-CFLAGS="-ansi"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); checkCFLAGS="$checkCFLAGS $CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_MSG_CHECKING([whether the C compiler accepts -pedantic])
+-CFLAGS="-pedantic"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); checkCFLAGS="$checkCFLAGS $CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_MSG_CHECKING([whether the C compiler accepts -Wall])
+-CFLAGS="-Wall"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); wallCFLAGS="$CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_MSG_CHECKING([whether the C compiler accepts -Werror])
+-CFLAGS="-Werror"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); pedanticCFLAGS="$wallCFLAGS $CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_MSG_CHECKING([whether the C compiler accepts -ffast-math])
+-CFLAGS="-ffast-math"
+-AC_TRY_COMPILE(,,AC_MSG_RESULT(yes); optCFLAGS="$optCFLAGS $CFLAGS",AC_MSG_RESULT(no))
+-
+-AC_ARG_ENABLE(wall,
+- [ --enable-wall compile with -ansi -pedantic -Wall -Werror],
+- [with_wall=$enableval],
+- [with_wall=no])
+-test "$with_wall" = "yes" && fullCFLAGS="$checkCFLAGS $wallCFLAGS $pendanticCFLAGS $fullCFLAGS"
+-
+-temp2CFLAGS="$tempCFLAGS $optCFLAGS"
+-
+-AC_ARG_ENABLE(debug,
+- [ --enable-debug compile for debugger compatibility],
+- [with_debug=$enableval],
+- [with_debug=no])
+-test "$with_debug" = "yes" && temp2CFLAGS="$wallCFLAGS $debugCFLAGS"
+-
+-AC_ARG_ENABLE(efence,
+- [ --enable-efence debug build + link with electric fence],
+- [with_efence=$enableval],
+- [with_efence=no])
+-test "$with_efence" = "yes" && temp2CFLAGS="$debugCFLAGS" && LIBS="-lefence"
+-
+-DEBUG="$debugCFLAGS $fullCFLAGS"
+-fullCFLAGS="$temp2CFLAGS $fullCFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+-CFLAGS="$checkCFLAGS -D__USE_BSD -D_BSD_SOURCE -D__USE_POSIX -D_POSIX_SOURCE -D_POSIX_MAPPED_FILES"
++
++fullCFLAGS="$optCFLAGS $fullCFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
++CFLAGS="$fullCFLAGS" # -D__USE_BSD -D_BSD_SOURCE -D__USE_POSIX -D_POSIX_SOURCE -D_POSIX_MAPPED_FILES"
+
+ dnl Checks for libraries.
+
+@@ -124,6 +63,4 @@
+
+ dnl Done with tests
+
+-CFLAGS="$fullCFLAGS"
+-
+ AC_OUTPUT(Makefile)
+--- a/Makefile.in 2003-08-31 03:18:03.000000000 +0200
++++ b/Makefile.in 2010-09-19 05:50:30.000000000 +0200
+@@ -31,7 +31,7 @@
+ all: $(REQ) $(BIN)
+
+ $(BIN): main.o wipe.o rand.o dir.o file.o blkdev.o lock.o text.o str.o percent.o prompt.o io.o mt.o
+- $(CC) $(LIBS) *.o -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LIBS) *.o -o $@
+
+
+ # restores everything to a pre-configured state
diff --git a/app-misc/wipe/wipe-2.2.20050509-r1.ebuild b/app-misc/wipe/wipe-2.2.20050509-r1.ebuild
new file mode 100644
index 000000000000..70b508b05aad
--- /dev/null
+++ b/app-misc/wipe/wipe-2.2.20050509-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.2.20050509-r1.ebuild,v 1.1 2010/09/19 03:56:16 jer Exp $
+
+EAPI="2"
+
+inherit autotools toolchain-funcs versionator
+
+MY_PV=$(get_version_component_range 3)
+MY_SRC=${PN}-wip-${MY_PV}
+S="${WORKDIR}/${PN}"
+
+DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
+HOMEPAGE="http://wipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wipe/${MY_SRC}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="!sys-cluster/lam-mpi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die emake failed
+}
+
+src_install() {
+ dobin wipe || die "dobin failed"
+ doman wipe.1
+ dodoc CHANGES README TODO TESTING
+}
+
+pkg_postinst() {
+ elog "Note that wipe is useless on journalling filesystems, such as reiserfs or XFS."
+ elog "See documentation for more info."
+}