summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-27 20:23:43 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-27 20:23:43 +0000
commit2bb8a3e7d320a61dff95c8fe335ca3f5cd80192d (patch)
tree99b128e857ec74421690bff62845d0f6ea57801c /app-misc
parentVersion bumped. (diff)
downloadgentoo-2-2bb8a3e7d320a61dff95c8fe335ca3f5cd80192d.tar.gz
gentoo-2-2bb8a3e7d320a61dff95c8fe335ca3f5cd80192d.tar.bz2
gentoo-2-2bb8a3e7d320a61dff95c8fe335ca3f5cd80192d.zip
Version bumped.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gallery/ChangeLog7
-rw-r--r--app-misc/gallery/Manifest4
-rw-r--r--app-misc/gallery/files/digest-gallery-1.4.11
-rw-r--r--app-misc/gallery/gallery-1.4.1.ebuild66
4 files changed, 75 insertions, 3 deletions
diff --git a/app-misc/gallery/ChangeLog b/app-misc/gallery/ChangeLog
index c5c18e27bc55..8d39c80e9937 100644
--- a/app-misc/gallery/ChangeLog
+++ b/app-misc/gallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gallery
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gallery/ChangeLog,v 1.14 2003/11/24 09:49:58 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gallery/ChangeLog,v 1.15 2003/11/27 20:23:38 mholzer Exp $
+
+*gallery-1.4.1 (27 Nov 2003)
+
+ 27 Nov 2003; Martin Holzer <mholzer@gentoo.org> gallery-1.4.1.ebuild:
+ Version bumped.
*gallery-1.4.1_rc4 (24 Nov 2003)
diff --git a/app-misc/gallery/Manifest b/app-misc/gallery/Manifest
index 00683df5ba25..58c9282b543b 100644
--- a/app-misc/gallery/Manifest
+++ b/app-misc/gallery/Manifest
@@ -1,8 +1,8 @@
MD5 7ade084ecabde894f7f88fb29e0eea08 gallery-1.4_p2.ebuild 2431
MD5 24696e49e277f3cec79aff19ec88a07f gallery-1.4.1_rc4.ebuild 1869
MD5 c339473e0ff43da76eb2f2607c441921 metadata.xml 280
-MD5 bb2a6a3638160f1882ca9deb8dbfd5eb gallery-1.4.1.ebuild 1806
-MD5 4aac46e9cb31f2b53963ab86bed6a8c5 ChangeLog 1682
+MD5 834f5eaf1a038cc80f6d695cf5ee8217 gallery-1.4.1.ebuild 1802
+MD5 1b008b1007248f6658a649831564f371 ChangeLog 1803
MD5 32c98a33a09366f4f5eeaf54cce66a2b files/digest-gallery-1.4.1_rc4 69
MD5 44ef29bfa9165ad28d6de638d9c64cb5 files/digest-gallery-1.4.1 65
MD5 a9b8e52b9d14c6b3a74d3b71cb0dc038 files/digest-gallery-1.4_p2 68
diff --git a/app-misc/gallery/files/digest-gallery-1.4.1 b/app-misc/gallery/files/digest-gallery-1.4.1
new file mode 100644
index 000000000000..f309760d51d3
--- /dev/null
+++ b/app-misc/gallery/files/digest-gallery-1.4.1
@@ -0,0 +1 @@
+MD5 7152ba06c6c879695cefd260acfd9b8f gallery-1.4.1.tar.gz 927358
diff --git a/app-misc/gallery/gallery-1.4.1.ebuild b/app-misc/gallery/gallery-1.4.1.ebuild
new file mode 100644
index 000000000000..dbbfcd66387d
--- /dev/null
+++ b/app-misc/gallery/gallery-1.4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gallery/gallery-1.4.1.ebuild,v 1.1 2003/11/27 20:23:38 mholzer Exp $
+
+inherit webapp-apache
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator."
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
+DEPEND=">=net-www/apache-1.3.24-r1
+ >=dev-php/mod_php-4.1.2-r5
+ >=media-gfx/jhead-1.6
+ >=media-libs/netpbm-9.12
+ >=media-gfx/imagemagick-5.4.9.1-r1"
+
+S=${WORKDIR}/${PN}
+
+webapp-detect || NO_WEBSERVER=1
+
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_install() {
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+ dodir ${destdir}
+ dodoc AUTHORS ChangeLog README LICENSE.txt
+ rm -rf ChangeLog
+
+ cp -r . ${D}/${HTTPD_ROOT}/${PN}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
+ # Fix permissions
+ find ${D}${destdir} -type d | xargs chmod 755
+ find ${D}${destdir} -type f | xargs chmod 644
+
+ #dohtml docs/*
+}
+
+pkg_postinst() {
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+# chown -R apache.apache ${DST_PATH}
+ chown root.root ${destdir}/secure.sh ${destdir}/configure.sh
+ chmod 700 ${destdir}/secure.sh ${destdir}/configure.sh
+
+ einfo
+ einfo "For new installations point your browser to "
+ einfo "http://www.yourhost.com/gallery/setup/"
+ einfo "and follow the instructions."
+ einfo "--------------------------------------------"
+ einfo "For upgrades, just run"
+ einfo "# cd ${destdir}"
+ einfo "# sh ./secure.sh"
+ einfo
+}