summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-06-24 07:10:51 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-06-24 07:10:51 +0000
commit2e9b54c619d15e2c258f93be33ee6fab0b86dbc3 (patch)
tree27384b1022e26d493dfa0bf682b192248c4b12d0 /app-misc
parentStable on amd64 wrt bug #322791 (diff)
downloadgentoo-2-2e9b54c619d15e2c258f93be33ee6fab0b86dbc3.tar.gz
gentoo-2-2e9b54c619d15e2c258f93be33ee6fab0b86dbc3.tar.bz2
gentoo-2-2e9b54c619d15e2c258f93be33ee6fab0b86dbc3.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/alexandria/ChangeLog8
-rw-r--r--app-misc/alexandria/alexandria-0.6.6.ebuild71
-rw-r--r--app-misc/alexandria/files/alexandria-0.6.6-Rakefile.patch14
3 files changed, 92 insertions, 1 deletions
diff --git a/app-misc/alexandria/ChangeLog b/app-misc/alexandria/ChangeLog
index aebc7eff5ac3..e2be946dcc17 100644
--- a/app-misc/alexandria/ChangeLog
+++ b/app-misc/alexandria/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/alexandria
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.36 2010/04/08 07:17:26 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.37 2010/06/24 07:10:51 fauli Exp $
+
+*alexandria-0.6.6 (24 Jun 2010)
+
+ 24 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
+ +alexandria-0.6.6.ebuild, +files/alexandria-0.6.6-Rakefile.patch:
+ version bump
08 Apr 2010; Christian Faulhammer <fauli@gentoo.org> metadata.xml:
take over maintainership
diff --git a/app-misc/alexandria/alexandria-0.6.6.ebuild b/app-misc/alexandria/alexandria-0.6.6.ebuild
new file mode 100644
index 000000000000..72ab39e6051c
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.6.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.6.ebuild,v 1.1 2010/06/24 07:10:51 fauli Exp $
+
+inherit gnome2 ruby
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="evo"
+
+DOCS="ChangeLog README TODO"
+
+RDEPEND=">=dev-lang/ruby-1.8.0
+ >=dev-ruby/ruby-gettext-0.6.1
+ >=dev-ruby/ruby-gnome2-0.16.0
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0
+ >=dev-ruby/imagesize-0.1.1
+ dev-ruby/hpricot
+ evo? ( >=dev-ruby/revolution-0.5 )"
+
+DEPEND=">=dev-lang/ruby-1.8.0
+ app-text/scrollkeeper
+ dev-ruby/rake"
+
+PATCHES=(
+ "${FILESDIR}/${P}-Rakefile.patch"
+)
+
+src_compile() {
+ rake || die
+}
+
+src_install() {
+ export PREFIX="${D}/usr"
+ rake install || die
+
+ [ -n "${DOCS}" ] && dodoc ${DOCS}
+
+ # Move the installed docs to the gentoo standard directory
+ for doc in "${D}/usr/share/doc/alexandria/*"
+ do
+ dodoc $doc
+ done
+ rm -rf "${D}/usr/share/doc/alexandria"
+}
+
+pkg_postinst() {
+ unset PREFIX
+
+ gnome2_gconf_install
+
+ # For the next line see bug #76726
+ "${ROOT}/usr/bin/gconftool-2" --shutdown
+
+ echo
+ elog "To enable some book providers you will need to emerge"
+ elog "additional packages:"
+ echo
+ elog " For the Deastore book provider:"
+ elog " dev-ruby/htmlentities"
+ echo
+ elog " For Z39.50 support and the Library of Congress and"
+ elog " British Library book proviers:"
+ elog " dev-ruby/ruby-zoom"
+}
diff --git a/app-misc/alexandria/files/alexandria-0.6.6-Rakefile.patch b/app-misc/alexandria/files/alexandria-0.6.6-Rakefile.patch
new file mode 100644
index 000000000000..8407df100382
--- /dev/null
+++ b/app-misc/alexandria/files/alexandria-0.6.6-Rakefile.patch
@@ -0,0 +1,14 @@
+--- Rakefile.orig 2010-06-24 09:07:45.490965359 +0200
++++ Rakefile 2010-06-24 09:08:01.968715044 +0200
+@@ -344,10 +344,8 @@
+ system("gtk-update-icon-cache -f -t /usr/share/icons/hicolor") # HACK
+ end
+
+-task :post_install => [:scrollkeeper, :gconf, :update_icon_cache]
+-
+ desc "Install Alexandria"
+-task :install => [:pre_install, :install_package, :post_install]
++task :install => [:pre_install, :install_package]
+
+ desc "Uninstall Alexandria"
+ task :uninstall => [:uninstall_package] # TODO gconf etc...