summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2010-07-13 00:51:50 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2010-07-13 00:51:50 +0000
commit31b78bc8fe1d86ff261faeca754bcfd2bef58a97 (patch)
treef351b19ca86f6878ae08d3880763fb1409f8f10e /app-misc
parentFix OpenSSL >= 1.0.0 detection (broken m4/tls.m4 check) wrt #328027. (diff)
downloadgentoo-2-31b78bc8fe1d86ff261faeca754bcfd2bef58a97.tar.gz
gentoo-2-31b78bc8fe1d86ff261faeca754bcfd2bef58a97.tar.bz2
gentoo-2-31b78bc8fe1d86ff261faeca754bcfd2bef58a97.zip
Version bump; changed dependencies so python-poppler is only required for PDF export or printing
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gourmet/ChangeLog9
-rw-r--r--app-misc/gourmet/gourmet-0.15.4-r1.ebuild8
-rw-r--r--app-misc/gourmet/gourmet-0.15.5.ebuild51
-rw-r--r--app-misc/gourmet/metadata.xml6
4 files changed, 66 insertions, 8 deletions
diff --git a/app-misc/gourmet/ChangeLog b/app-misc/gourmet/ChangeLog
index 406288c663c6..461cb74b1921 100644
--- a/app-misc/gourmet/ChangeLog
+++ b/app-misc/gourmet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/gourmet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gourmet/ChangeLog,v 1.10 2010/07/12 01:43:54 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gourmet/ChangeLog,v 1.11 2010/07/13 00:51:50 nixphoeni Exp $
+
+*gourmet-0.15.5 (13 Jul 2010)
+
+ 13 Jul 2010; Joe Sapp <nixphoeni@gentoo.org> gourmet-0.15.4-r1.ebuild,
+ +gourmet-0.15.5.ebuild, metadata.xml:
+ Version bump; changed dependencies so python-poppler is only required for
+ PDF export or printing
*gourmet-0.15.4-r1 (12 Jul 2010)
diff --git a/app-misc/gourmet/gourmet-0.15.4-r1.ebuild b/app-misc/gourmet/gourmet-0.15.4-r1.ebuild
index 4699af6f0bf6..2537d880e430 100644
--- a/app-misc/gourmet/gourmet-0.15.4-r1.ebuild
+++ b/app-misc/gourmet/gourmet-0.15.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gourmet/gourmet-0.15.4-r1.ebuild,v 1.1 2010/07/12 01:43:54 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gourmet/gourmet-0.15.4-r1.ebuild,v 1.2 2010/07/13 00:51:50 nixphoeni Exp $
EAPI="2"
PYTHON_DEPEND="2:2.4"
@@ -28,11 +28,11 @@ RDEPEND=">=dev-python/pygtk-2.3.93
=dev-python/sqlalchemy-0.5.8
dev-python/imaging
dev-python/gtkspell-python
- dev-python/python-poppler
dev-db/metakit[python]
- pdf? ( dev-python/reportlab )
+ pdf? ( dev-python/reportlab dev-python/python-poppler )
rtf? ( dev-python/pyrtf )
- gnome-print? ( >=dev-python/libgnomeprint-python-2 )"
+ gnome-print? ( >=dev-python/libgnomeprint-python-2
+ dev-python/python-poppler )"
DEPEND="${RDEPEND}"
RESTRICT_PYTHON_ABIS="3.*"
diff --git a/app-misc/gourmet/gourmet-0.15.5.ebuild b/app-misc/gourmet/gourmet-0.15.5.ebuild
new file mode 100644
index 000000000000..d69596f27954
--- /dev/null
+++ b/app-misc/gourmet/gourmet-0.15.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gourmet/gourmet-0.15.5.ebuild,v 1.1 2010/07/13 00:51:50 nixphoeni Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils python
+
+DESCRIPTION="Recipe Organizer and Shopping List Generator for Gnome"
+HOMEPAGE="http://grecipe-manager.sourceforge.net/"
+SRC_URI="mirror://sourceforge/grecipe-manager/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-print pdf rtf"
+
+# I wish there were a better way to check if the current Python version
+# was built with the 'sqlite' use flag and, if it wasn't, pull in pysqlite,
+# but I'm not sure how.
+RDEPEND=">=dev-python/pygtk-2.3.93
+ >=dev-python/libgnome-python-2
+ >=gnome-base/libglade-2
+ || ( dev-lang/python[sqlite]
+ dev-python/pysqlite:2 )
+ =dev-python/sqlalchemy-0.5.8
+ dev-python/imaging
+ dev-python/gtkspell-python
+ dev-db/metakit[python]
+ pdf? ( dev-python/reportlab dev-python/python-poppler )
+ rtf? ( dev-python/pyrtf )
+ gnome-print? ( >=dev-python/libgnomeprint-python-2
+ dev-python/python-poppler )"
+DEPEND="${RDEPEND}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+# distutils gets a bunch of default docs
+DOCS="TESTS FAQ"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r --quiet 2 .
+}
+
+src_install() {
+ distutils_src_install --disable-modules-check
+ doman gourmet.1
+}
diff --git a/app-misc/gourmet/metadata.xml b/app-misc/gourmet/metadata.xml
index 811419274354..2f8e259ff1bb 100644
--- a/app-misc/gourmet/metadata.xml
+++ b/app-misc/gourmet/metadata.xml
@@ -12,8 +12,8 @@
shopping lists from recipes. Gourmet imports recipes from a
number of sources, including MealMaster and MasterCook
archives and several popular websites. Gourmet can export
- recipes as text, MealMaster files, HTML web pages, and a
- custom XML format for exchange with other Gourmet users.
+ recipes as text, MealMaster files, HTML web pages, PDF, and
+ a custom XML format for exchange with other Gourmet users.
Gourmet supports linking images with recipes.
</longdescription>
<upstream>
@@ -24,7 +24,7 @@
</upstream>
<use>
<flag name='rtf'>Enable export to RTF</flag>
- <flag name='gnome-print'>Enable printing support using
+ <flag name='gnome-print'>Enable pretty Python printing with
gnome-print</flag>
</use>
</pkgmetadata>