summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-07-30 11:58:51 +0000
committerFabian Groffen <grobian@gentoo.org>2011-07-30 11:58:51 +0000
commit321647a7973374bfa39cd1bd29b8e19f1457aea8 (patch)
tree3d347b0b4b4f25abe4621f1fde18035eb30335d7 /app-misc
parentDrop ~sparc-fbsd KEYWORD (diff)
downloadgentoo-2-321647a7973374bfa39cd1bd29b8e19f1457aea8.tar.gz
gentoo-2-321647a7973374bfa39cd1bd29b8e19f1457aea8.tar.bz2
gentoo-2-321647a7973374bfa39cd1bd29b8e19f1457aea8.zip
Fix for Darwin (bug #376045) and Prefix
(Portage version: 2.2.01.19011-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tmux/ChangeLog6
-rw-r--r--app-misc/tmux/files/tmux-1.5-darwin.patch78
-rw-r--r--app-misc/tmux/tmux-1.5.ebuild13
-rw-r--r--app-misc/tmux/tmux-9999.ebuild6
4 files changed, 100 insertions, 3 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index 7d2300db39dc..eebf81d63a3a 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/tmux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.64 2011/07/13 09:20:03 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.65 2011/07/30 11:58:51 grobian Exp $
+
+ 30 Jul 2011; Fabian Groffen <grobian@gentoo.org> tmux-1.5.ebuild,
+ +files/tmux-1.5-darwin.patch, tmux-9999.ebuild:
+ Fix for Darwin (bug #376045) and Prefix
*tmux-1.5 (13 Jul 2011)
diff --git a/app-misc/tmux/files/tmux-1.5-darwin.patch b/app-misc/tmux/files/tmux-1.5-darwin.patch
new file mode 100644
index 000000000000..515c4e8acc51
--- /dev/null
+++ b/app-misc/tmux/files/tmux-1.5-darwin.patch
@@ -0,0 +1,78 @@
+http://sourceforge.net/tracker/?func=detail&aid=3376684&group_id=200378&atid=973262
+
+
+--- configure.ac
++++ configure.ac
+@@ -124,6 +124,7 @@
+ # Look for networking libraries.
+ AC_SEARCH_LIBS(b64_ntop, resolv)
+ AC_SEARCH_LIBS(__b64_ntop, resolv)
++AC_SEARCH_LIBS(res_9_b64_ntop, resolv)
+ AC_SEARCH_LIBS(inet_ntoa, nsl)
+ AC_SEARCH_LIBS(socket, socket)
+ AC_CHECK_LIB(xnet, socket)
+--- configure
++++ configure
+@@ -4718,6 +4718,62 @@
+
+ fi
+
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing res_9_b64_ntop" >&5
++$as_echo_n "checking for library containing res_9_b64_ntop... " >&6; }
++if test "${ac_cv_search_res_9_b64_ntop+set}" = set; then :
++ $as_echo_n "(cached) " >&6
++else
++ ac_func_search_save_LIBS=$LIBS
++cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++/* end confdefs.h. */
++
++/* Override any GCC internal prototype to avoid an error.
++ Use char because int might match the return type of a GCC
++ builtin and then its argument prototype would still apply. */
++#ifdef __cplusplus
++extern "C"
++#endif
++char res_9_b64_ntop ();
++int
++main ()
++{
++return res_9_b64_ntop ();
++ ;
++ return 0;
++}
++_ACEOF
++for ac_lib in '' resolv; do
++ if test -z "$ac_lib"; then
++ ac_res="none required"
++ else
++ ac_res=-l$ac_lib
++ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
++ fi
++ if ac_fn_c_try_link "$LINENO"; then :
++ ac_cv_search_res_9_b64_ntop=$ac_res
++fi
++rm -f core conftest.err conftest.$ac_objext \
++ conftest$ac_exeext
++ if test "${ac_cv_search_res_9_b64_ntop+set}" = set; then :
++ break
++fi
++done
++if test "${ac_cv_search_res_9_b64_ntop+set}" = set; then :
++
++else
++ ac_cv_search_res_9_b64_ntop=no
++fi
++rm conftest.$ac_ext
++LIBS=$ac_func_search_save_LIBS
++fi
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_res_9_b64_ntop" >&5
++$as_echo "$ac_cv_search_res_9_b64_ntop" >&6; }
++ac_res=$ac_cv_search_res_9_b64_ntop
++if test "$ac_res" != no; then :
++ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
++
++fi
++
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing inet_ntoa" >&5
+ $as_echo_n "checking for library containing inet_ntoa... " >&6; }
+ if test "${ac_cv_search_inet_ntoa+set}" = set; then :
diff --git a/app-misc/tmux/tmux-1.5.ebuild b/app-misc/tmux/tmux-1.5.ebuild
index 8784145b049f..8e2b8e0c32c3 100644
--- a/app-misc/tmux/tmux-1.5.ebuild
+++ b/app-misc/tmux/tmux-1.5.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.5.ebuild,v 1.1 2011/07/13 09:20:03 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.5.ebuild,v 1.2 2011/07/30 11:58:51 grobian Exp $
EAPI=4
+inherit eutils autotools
+
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="http://tmux.sourceforge.net"
SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
@@ -41,6 +43,15 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-darwin.patch # drop on next release
+ eautoreconf # for darwin patch
+ # look for config file in the prefix
+ sed -i -e '/SYSTEM_CFG/s:"/etc:"'"${EPREFIX}"'/etc:' tmux.h || die
+ # and don't just add some includes
+ sed -i -e 's:-I/usr/local/include::' Makefile.in || die
+}
+
src_install() {
default
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index 907f267a2f83..74c21485c81e 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-9999.ebuild,v 1.4 2011/06/02 18:06:50 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-9999.ebuild,v 1.5 2011/07/30 11:58:51 grobian Exp $
EAPI=3
@@ -30,6 +30,10 @@ S="${WORKDIR}"/${PN}
src_prepare() {
eautoreconf
+ # look for config file in the prefix
+ sed -i -e '/SYSTEM_CFG/s:"/etc:"'"${EPREFIX}"'/etc:' tmux.h || die
+ # and don't just add some includes
+ sed -i -e 's:-I/usr/local/include::' Makefile.in || die
}
src_configure() {