summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2012-07-31 15:49:34 +0000
committerCédric Krier <cedk@gentoo.org>2012-07-31 15:49:34 +0000
commit574f2047ac8d25d4e75ca5129abf6a938d7f90bb (patch)
tree44e4e670cec91db4d136a359512add940fb77afd /app-misc
parentRemove obsolete patch file (diff)
downloadgentoo-2-574f2047ac8d25d4e75ca5129abf6a938d7f90bb.tar.gz
gentoo-2-574f2047ac8d25d4e75ca5129abf6a938d7f90bb.tar.bz2
gentoo-2-574f2047ac8d25d4e75ca5129abf6a938d7f90bb.zip
Fix respect of LDFLAGS for Bug #331817
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/i810switch/ChangeLog10
-rw-r--r--app-misc/i810switch/files/i810switch-ldflags.patch12
-rw-r--r--app-misc/i810switch/i810switch-0.6.5-r3.ebuild39
-rw-r--r--app-misc/i810switch/i810switch-0.6.5.ebuild26
4 files changed, 59 insertions, 28 deletions
diff --git a/app-misc/i810switch/ChangeLog b/app-misc/i810switch/ChangeLog
index 6cf9676c55e7..1fb7cad66155 100644
--- a/app-misc/i810switch/ChangeLog
+++ b/app-misc/i810switch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/i810switch
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/i810switch/ChangeLog,v 1.20 2009/09/23 16:03:09 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/i810switch/ChangeLog,v 1.21 2012/07/31 15:49:34 cedk Exp $
+
+*i810switch-0.6.5-r3 (31 Jul 2012)
+
+ 31 Jul 2012; Cédric Krier <cedk@gentoo.org> +files/i810switch-ldflags.patch,
+ -i810switch-0.6.5.ebuild, +i810switch-0.6.5-r3.ebuild:
+ Fix respect of LDFLAGS for Bug #331817
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> i810switch-0.6.5.ebuild:
Remove virtual/libc
diff --git a/app-misc/i810switch/files/i810switch-ldflags.patch b/app-misc/i810switch/files/i810switch-ldflags.patch
new file mode 100644
index 000000000000..8f95c6bed8e2
--- /dev/null
+++ b/app-misc/i810switch/files/i810switch-ldflags.patch
@@ -0,0 +1,12 @@
+diff -ru i810switch-0.6.5/Makefile i810switch-0.6.5.new/Makefile
+--- i810switch-0.6.5/Makefile 2003-12-31 15:51:40.000000000 +0100
++++ i810switch-0.6.5.new/Makefile 2012-07-31 17:41:50.000000000 +0200
+@@ -6,7 +6,7 @@
+ all: i810switch
+
+ i810switch: $(OBJECTS)
+- $(CC) $(CFLAGS) -o $@ $(OBJECTS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJECTS)
+
+ install: i810switch
+ install -d $(DESTDIR)/usr/bin
diff --git a/app-misc/i810switch/i810switch-0.6.5-r3.ebuild b/app-misc/i810switch/i810switch-0.6.5-r3.ebuild
new file mode 100644
index 000000000000..06a29e7e5b83
--- /dev/null
+++ b/app-misc/i810switch/i810switch-0.6.5-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/i810switch/i810switch-0.6.5-r3.ebuild,v 1.1 2012/07/31 15:49:34 cedk Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A utility for switching the LCD and external VGA displays on and off"
+HOMEPAGE="http://www16.plala.or.jp/mano-a-mano/i810switch.html"
+SRC_URI="http://www16.plala.or.jp/mano-a-mano/i810switch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/pciutils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/i810switch-macbook-support.patch
+ epatch "${FILESDIR}"/i810switch-ldflags.patch
+ emake clean
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}
+
+pkg_postinst() {
+ einfo "To allow non-root users to use i810switch run:"
+ einfo " chmod u+s /usr/bin/i810switch"
+}
diff --git a/app-misc/i810switch/i810switch-0.6.5.ebuild b/app-misc/i810switch/i810switch-0.6.5.ebuild
deleted file mode 100644
index 51c70157072d..000000000000
--- a/app-misc/i810switch/i810switch-0.6.5.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/i810switch/i810switch-0.6.5.ebuild,v 1.4 2009/09/23 16:03:09 patrick Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="A utility for switching the LCD and external VGA displays on and off"
-HOMEPAGE="http://www16.plala.or.jp/mano-a-mano/i810switch.html"
-SRC_URI="http://www16.plala.or.jp/mano-a-mano/i810switch/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="sys-apps/pciutils"
-
-src_compile() {
- emake CC=$(tc-getCC) || die "compile failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog README TODO
-}