summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-08-27 16:33:08 +0000
committerIan Delaney <idella4@gentoo.org>2013-08-27 16:33:08 +0000
commit79ffbf7d055d5aeac89150471b2372a6aa1f9a83 (patch)
tree8fabd37f19cf11a2cbf1d9a2f8ac1ee762521bab /app-misc
parentversion bump (diff)
downloadgentoo-2-79ffbf7d055d5aeac89150471b2372a6aa1f9a83.tar.gz
gentoo-2-79ffbf7d055d5aeac89150471b2372a6aa1f9a83.tar.bz2
gentoo-2-79ffbf7d055d5aeac89150471b2372a6aa1f9a83.zip
revbump -> EAPI 5
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/beancounter/ChangeLog10
-rw-r--r--app-misc/beancounter/beancounter-0.8.10-r1.ebuild33
2 files changed, 40 insertions, 3 deletions
diff --git a/app-misc/beancounter/ChangeLog b/app-misc/beancounter/ChangeLog
index 46a7a8c8f573..5f9614a89424 100644
--- a/app-misc/beancounter/ChangeLog
+++ b/app-misc/beancounter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/beancounter
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beancounter/ChangeLog,v 1.15 2012/05/10 15:06:33 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beancounter/ChangeLog,v 1.16 2013/08/27 16:33:08 idella4 Exp $
+
+*beancounter-0.8.10-r1 (27 Aug 2013)
+
+ 27 Aug 2013; Ian Delaney <idella4@gentoo.org> +beancounter-0.8.10-r1.ebuild:
+ revbump -> EAPI 5
10 May 2012; Agostino Sarubbo <ago@gentoo.org> -beancounter-0.8.8.ebuild,
-beancounter-0.8.9.ebuild:
@@ -67,4 +72,3 @@
04 May 2005; Christian Andreetta <satya@gentoo.org> +metadata.xml,
+beancounter-0.8.1.ebuild:
initial submission
-
diff --git a/app-misc/beancounter/beancounter-0.8.10-r1.ebuild b/app-misc/beancounter/beancounter-0.8.10-r1.ebuild
new file mode 100644
index 000000000000..92948d1b80eb
--- /dev/null
+++ b/app-misc/beancounter/beancounter-0.8.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beancounter/beancounter-0.8.10-r1.ebuild,v 1.1 2013/08/27 16:33:08 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Finance performance calculation engine with full data acquisition and SQL support"
+HOMEPAGE="http://dirk.eddelbuettel.com/code/beancounter.html"
+SRC_URI="http://eddelbuettel.com/dirk/code/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres sqlite"
+
+DEPEND="dev-perl/DateManip
+ dev-perl/Statistics-Descriptive
+ dev-perl/Finance-YahooQuote
+ dev-perl/libwww-perl
+ mysql? ( dev-perl/DBD-mysql )
+ sqlite? ( dev-perl/DBD-SQLite )
+ postgres? ( dev-perl/DBD-Pg )"
+
+RDEPEND="${DEPEND} dev-perl/DBI"
+mydoc="README example.beancounterrc beancounter_*.txt "
+
+src_install() {
+ perl-module_src_install
+ # rm unwanted READMEs
+ rm "${D}"usr/share/doc/${PF}/{README.Debian,README.non-gnu} || die
+}