summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-04 07:37:00 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-04 07:37:00 +0000
commitae6112b2d4ab6e290ccd8fdc66405289372b3e74 (patch)
tree7128b9f0cc85558456d72ea6a549de97f7c1fd59 /app-misc
parentmarked x86 per bug 410145 (diff)
downloadgentoo-2-ae6112b2d4ab6e290ccd8fdc66405289372b3e74.tar.gz
gentoo-2-ae6112b2d4ab6e290ccd8fdc66405289372b3e74.tar.bz2
gentoo-2-ae6112b2d4ab6e290ccd8fdc66405289372b3e74.zip
app-misc/astrolog: Move to EAPI=4, respect LDFLAGS, #240057
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/astrolog/ChangeLog10
-rw-r--r--app-misc/astrolog/astrolog-5.40-r1.ebuild69
-rw-r--r--app-misc/astrolog/metadata.xml14
3 files changed, 83 insertions, 10 deletions
diff --git a/app-misc/astrolog/ChangeLog b/app-misc/astrolog/ChangeLog
index 97421e2640a1..557dc735ae02 100644
--- a/app-misc/astrolog/ChangeLog
+++ b/app-misc/astrolog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/astrolog
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/astrolog/ChangeLog,v 1.12 2010/01/11 16:41:19 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/astrolog/ChangeLog,v 1.13 2012/04/04 07:37:00 jlec Exp $
+
+*astrolog-5.40-r1 (04 Apr 2012)
+
+ 04 Apr 2012; Justin Lecher <jlec@gentoo.org> +astrolog-5.40-r1.ebuild,
+ metadata.xml:
+ Move to EAPI=4, respect LDFLAGS, #240057
11 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> astrolog-5.40.ebuild:
Fixed propagation of compiler, bug #243606, thanks Arttu Valo
diff --git a/app-misc/astrolog/astrolog-5.40-r1.ebuild b/app-misc/astrolog/astrolog-5.40-r1.ebuild
new file mode 100644
index 000000000000..0e60bf858bea
--- /dev/null
+++ b/app-misc/astrolog/astrolog-5.40-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/astrolog/astrolog-5.40-r1.ebuild,v 1.1 2012/04/04 07:37:00 jlec Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="A many featured astrology chart calculation program"
+HOMEPAGE="http://www.astrolog.org/astrolog.htm"
+SRC_URI="http://www.astrolog.org/ftp/ast54unx.shr"
+
+LICENSE="astrolog"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ sh "${DISTDIR}"/ast54unx.shr || die
+}
+
+src_prepare() {
+ # remove stripping of created binary, dump hardcoded CFLAGS,
+ # respect CC (bug #243606), and CFLAGS (bug #240057)
+ sed \
+ -e 's:strip:#strip:' -e 's:^CFLAGS = :#CFLAGS = :' \
+ -e 's:\tcc :\t$(CC) $(CFLAGS) $(LDFLAGS) :' \
+ -i Makefile || die
+
+ # we use /usr/share/astrolog for config and (optional) ephemeris-data-files
+ sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h || die
+
+ # if we use X, we need to add -L/usr/X11R6/lib to compile succesful
+ #use X && sed -i -e "s:-lm -lX11:-lm -lX11 -L/usr/X11R6/lib:g" Makefile
+
+ # if we do NOT use X, we disable it by removing the -lX11 from the Makefile
+ # and remove the "#define X11" and "#define MOUSE" from astrolog.h
+ use X || ( sed -i -e "s:-lm -lX11:-lm:g" Makefile
+ sed -i -e "s:#define X11:/*#define X11:g" astrolog.h
+ sed -i -e "s:#define MOUSE:/*#define MOUSE:g" astrolog.h )
+
+ # any user may have an own astrolog configfile
+ #sed -i -e "s:astrolog.dat:astrolog.dat:g" astrolog.h
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin astrolog
+ dodoc Helpfile.540 README.1ST README.540 Update.540
+ insinto /usr/share/astrolog
+ doins astrolog.dat
+}
+
+pkg_postinst() {
+ ewarn "There is a sample config file /usr/share/astrolog/astrolog.dat"
+ ewarn "astrolog looks in current dir for a file astrolog.dat before"
+ ewarn "using the file in /usr/share/astrolog"
+ ewarn "If you want extended accuracy of astrolog's calculations you"
+ ewarn "can emerge the optional package \"astrolog-ephemeris\" which"
+ ewarn "needs ~4.7 MB additional diskspace for the ephemeris-files"
+}
diff --git a/app-misc/astrolog/metadata.xml b/app-misc/astrolog/metadata.xml
index e1ecd2ddc43c..cc1c4721fdb4 100644
--- a/app-misc/astrolog/metadata.xml
+++ b/app-misc/astrolog/metadata.xml
@@ -1,14 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-
-<maintainer>
- <email>george@gentoo.org</email>
- <name>George Shapovalov</name>
- <description>I'll be taking care of it. But since we need to have a herd in metadata
+ <herd>sci</herd>
+ <maintainer>
+ <email>george@gentoo.org</email>
+ <name>George Shapovalov</name>
+ <description>I'll be taking care of it. But since we need to have a herd in metadata
I've put sci there, as it seems the most related one.
</description>
-</maintainer>
-
+ </maintainer>
</pkgmetadata>