summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-11 16:41:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-11 16:41:19 +0000
commitb0f78277b363339dcd644b9bc63bc5c83a7f686e (patch)
tree0d9425f3fe1b533a2532f239d21bc4e4fdaf196d /app-misc
parentforget to actually check user USE settings (diff)
downloadgentoo-2-b0f78277b363339dcd644b9bc63bc5c83a7f686e.tar.gz
gentoo-2-b0f78277b363339dcd644b9bc63bc5c83a7f686e.tar.bz2
gentoo-2-b0f78277b363339dcd644b9bc63bc5c83a7f686e.zip
Fixed propagation of compiler, bug #243606, thanks Arttu Valo
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/astrolog/ChangeLog8
-rw-r--r--app-misc/astrolog/astrolog-5.40.ebuild24
2 files changed, 22 insertions, 10 deletions
diff --git a/app-misc/astrolog/ChangeLog b/app-misc/astrolog/ChangeLog
index 82566e6eb7f6..97421e2640a1 100644
--- a/app-misc/astrolog/ChangeLog
+++ b/app-misc/astrolog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/astrolog
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/astrolog/ChangeLog,v 1.11 2007/07/22 10:06:45 omp Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/astrolog/ChangeLog,v 1.12 2010/01/11 16:41:19 bicatali Exp $
+
+ 11 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> astrolog-5.40.ebuild:
+ Fixed propagation of compiler, bug #243606, thanks Arttu Valo
+
22 Jul 2007; David Shakaryan <omp@gentoo.org> astrolog-5.40.ebuild:
Remove virtual/x11 from dependencies.
diff --git a/app-misc/astrolog/astrolog-5.40.ebuild b/app-misc/astrolog/astrolog-5.40.ebuild
index a454861f4444..96ef16c7e462 100644
--- a/app-misc/astrolog/astrolog-5.40.ebuild
+++ b/app-misc/astrolog/astrolog-5.40.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/astrolog/astrolog-5.40.ebuild,v 1.13 2010/01/01 17:56:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/astrolog/astrolog-5.40.ebuild,v 1.14 2010/01/11 16:41:19 bicatali Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
DESCRIPTION="A many featured astrology chart calculation program"
HOMEPAGE="http://www.astrolog.org/astrolog.htm"
@@ -8,19 +12,23 @@ SRC_URI="http://www.astrolog.org/ftp/ast54unx.shr"
LICENSE="astrolog"
SLOT="0"
-KEYWORDS="x86 ppc64 ppc amd64"
+KEYWORDS="amd64 ppc ppc64 x86"
IUSE="X"
DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
-S=${WORKDIR}
+S="${WORKDIR}"
src_unpack() {
- bash "${DISTDIR}"/ast54unx.shr
- cd "${S}"
+ sh "${DISTDIR}"/ast54unx.shr
+}
- # remove stripping of created binary and substituce CFLAGS
- sed -i -e "s:strip:#strip:" -e "s:= -O:= ${CFLAGS}:" Makefile
+src_prepare() {
+ # remove stripping of created binary, dump hardcoded CFLAGS,
+ # respect CC (bug #243606), and CFLAGS (bug #240057)
+ sed -i -e 's:strip:#strip:' -e 's:^CFLAGS = :#CFLAGS = :' \
+ -e 's:\tcc :\t$(CC) $(CFLAGS) :' Makefile
# we use /usr/share/astrolog for config and (optional) ephemeris-data-files
sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h
@@ -39,7 +47,7 @@ src_unpack() {
}
src_compile() {
- emake || die
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install() {